Avoid clicks in SynthDefs

I have been making some SynthDefs to work with tidal for quite some time and I still haven't figure out a way on how to avoid clicks at the end of the sound. I think this happens because SuperDirt frees the SynthDef at the end of the event before the envelope goes back to 0. Does anyone has a solution for this?

Raising legato value usually solves that problem

1 Like

Yes that works in a lot of cases. I was wondering if someone has other solutions

For me increasing fadeTime parameter usually helps. I think in SuperDirt its 0.001 by default. U can try bigger values than that (e.g. # fadeTime 0.1).
Or u can change it in SuperDirt startup file by adding something like lines below:

~dirt.orbits[3].set(\fadeTime, 0.01);
~dirt.orbits[4].set(\fadeTime, 0.1);

Then d4 and d5 orbits have 0.01 and 0.1 fadeTime by default and I dont need to add # fadeTime parameter.

From my experience it always works fine for synths but sometimes can reduce snppiness for percussion (sometimes its a good thing) :slight_smile:

2 Likes

very interesting thanks!