Could not find Sound.Tidal.Context

Hi I'm trying to install Tidal and going through the troubleshooting steps. Those have taken me through Haskell installation, confirming ghci is installed and using the cabal commands. Now I am trying to confirm the Library is installed, and I get this error message:

: error:

Could not find module ‘Sound.Tidal.Context’

It is not a module in the current program, or in any known package.

There have been NO errors during the installation process, but also I am a permanent state of confusion with Unix so you never know, Anyway, looking for any insight into how I get this Library successfully installed, so that I can then check on SuperDirt.

If this is any clue, I can get the t> prompt in Atom, but can't get any sound out of that. Is that a Library issue?

Thanks to any and all

What Operating System are you using? Understanding the distribution you're installing on will help immensely!

I'm not sure of @yaxu's best troubleshooting procedure, but if you have no other haskell/cabal/ghc/supercollider usage, then the nuke option I find is relatively effective:

As your user (no need to sudo):

$ rm -rf ~/.ghc ~/.cabal ~/.local/share/SuperCollider ~/.config/SuperCollider

in your case, it sounds like your issue is solely requiring the .ghc and .cabal dirs removed to start again - this wipes out all the "userspace" stuff that gets setup by your cabal update/install commands, and can occasionally leave you in this dependency hell that you're experiencing.

If you are using any of ubuntu 20.04/Mint 20/debian 10, then I would recommend having a look at this installer process I'm working on, which takes care of all the heavy lifting for you (you will still want to nuke your directories above though before running):

(Older distros are passing, but I'm still not 100% sure of ansible module version capability - working on that verification right now :slight_smile: )

Thanks cleary, I'm on Mac OS 10.15.5, dumb of me not to put that in there

Will try the nuke option and see what gives

I think the OS especially matters here because that command is not in Mac OS Terminal

yes, OSX installs everything into somewhere else, and I'm afraid I am totally clueless as to where that is :stuck_out_tongue:

Did you get anywhere with this? What happens if you run (in terminal):

cabal update

and then

cabal install tidal

Yes, as above I ran both those cabal commands, which were successful, and the error came AFTER running those, i.e. "Could not find module 'Sound.Tidal.Context'

Hi I am new to this and literally have the same error. Just followed all the instructions and am installing on a macOS Mojave 10.14.6.

Got to the part where I test the install with d1 $ sound "bd sn" and it says error:

Ambiguous module name ‘Sound.Tidal.Context’:
  it was found in multiple packages: tidal-1.4.8 tidal-1.4.8

Variable not in scope: d1 :: t0 -> t

• Variable not in scope: sound :: [Char] -> t0
• Perhaps you meant ‘round’ (imported from Prelude)

Isn't this the same error?

Any help appreciated!!

@gtra1n what's causing that error? Are you getting it when you try to run import sound.tidal.context?

What happens when you run SuperDirt.start in SuperCollider? What happens when you boot tidal in Atom and run something like d1 $ sound "arpy"?

Also what install method did you use to start with?

Hi @lucyjp786

Did you try following the troubleshooting instructions? If you go through those step by step it should help you work out what's gone wrong.

Which method did you use to install tidal?

I've cleared the error now, I can't identify any particular step that resolved this, but I rebooted my computer, ran cabal update and install library again, ran through the trouble shooting steps and this time was able to run install on SuperDirt in Supercollider, then relaunched Supercollider and the SuperDirt started. Again, didn't do anything different other than rebooting computer and going through the same steps.

How odd. At least you got it all working though!