Help installing sc3plugins 3.11.1

I am running Windows 10 64bit, and thus far have installed SuperCollider 3.12.1, Haskell, and SuperDirt. I try to install Tidal Cycles from windows Powershell, using "choco install Tidalcycles" and I get the error:

  • TidalCycles (exited 1) - TidalCycles not installed. An error occurred during installation:
    Unable to resolve dependency 'sc3plugins (≥ 3.11.1)'.

I have tried multiple ways to download and move folders into the Extensions folder for Super Collider, and still when I try to install Tidal Cycles it tells me that it can't resolve dependency on sc3plugins 3.11.1

I managed to install sc3plugins 3.09, but can't get it to upgrade to 3.11.1.

Any ideas on how to resolve this and move forward with installing Tidal Cycles?
Thanks for your help in advance!

1 Like

Just encountered that myself. I've sent a message to @kindohm and @paulchannelstrip via the chocolatey website. Looks like 3.11.1 failed to publish properly and yet the current tidalcycles package wants that version.

Same issue here too. I tried installing the full package on Windows 10 via PowerShell/Chocolatey, but it failed after downloading SuperCollider with the same error (unable to resolve dependency 'scplugins (= 3.11.1)').

sc3-plugins are not required to run TidalCycles. They are just a set of handy plugins for SC which are also used in SuperDirt.
You can install Tidal separatly with cabal following the instructions provided at Windows | Tidal Cycles in the manual installation paragraph. Then you just download sc3-plugins from here Releases | sc3-plugins and drag them into your Supercollider extension folder

1 Like

Thanks, managed to get everything going through manual installation. Looking forward to having some fun now!

Same here. Seems it was a Chocolatey installer issue, all good, cheers!