Silent fail when trying to upgrade to tidal 1.4.9

Hi @ofiuco! This seems to be a bug in cabal. I've moved your post to a thread where others have had the same problem. The (hopeful) solution is in this post -> Silent fail when trying to upgrade to tidal 1.4.9 - #5 by yaxu


Thank you! Totally worked!!

1 Like

Thanks so much. I was having exactly the same problem and this seems to have fixed it.

I'm useless with Terminal can. I'm guessing the first line "rm -rf" is something like uninstall/remove and then reeinstall?

Actually, rm -rf is a shorthand for rm -r -f, which in turn is a shorthand for rm --recursive --force. It means force remove recursively. That is to say, remove the folders given (~/.ghc and ~/.cabal) and their subfolders at any rate.
These kinds of folders often contain files and folders with read-only flags set. When that's the case and you omit the -f flag in the rm command, you'll have to acknowledge each single file.
I encourage you to read the documentation for the rm command. Enter man rm.

1 Like

I'm in Windows too and this worked fine! Thank you @yaxu

1 Like