Something has gone wrong with my Mac install

... and I don't know how to fix it. I'm on Catalina 10.15.7.
When I open SC it seems to be working: 'listening to Tidal on port 57120'
When I open Atom, when I shift-return a line of code, I get the following output:

Choose ghcup default path: /Users/mpd3/.ghcup/bin
Ghci command: /Users/mpd3/.ghcup/bin/ghci
Ghc-pkg command: /Users/mpd3/.ghcup/bin/ghc-pkg
Load BootTidal.hs from /Users/mpd3/.atom/packages/tidalcycles/lib/BootTidal.hs
t> 
t> Loaded package environment from /Users/mpd3/.ghc/x86_64-darwin-8.8.3/environments/default
t> 
t> [TidalCycles version 1.7.8]
Installed in /Users/mpd3/.cabal/store/ghc-8.8.3/tdl-1.7.8-384b419a/share
Listening for external controls on 127.0.0.1:6010
t>  
t> Waiting for SuperDirt (v.1.7.2 or higher)..

No sound plays. What can I do to fix it? Thanks in advance!

I deleted .ghcup and .ghc, and ran the install script again, and I'm now not getting the error report (ie, the text in red in the Tidal output), but still no sound output. SC makes sound, and the SuperDirt sample folders are full. Thanks in advance for any help.

Other things I've tried:

Quarks.install("SuperDirt") returns

Installing SuperDirt
Installing Vowel
Vowel installed
Installing Dirt-Samples
Dirt-Samples installed
SuperDirt installed
-> Quark: SuperDirt[439960c38a47c73aa0a83f5c5077f8ec1ae52cb2]

in the SC console.

which cabal in the terminal returns
/Users/mpd3/.ghcup/bin/cabal
I tried changing the path in the Atom plug in to /Users/mpd3/.ghcup/bin/ghci but no joy. Haskell version is 8.10.5. tidal_version returns 1.7.8.

Giving up hope a little after trawling through the forums. :slightly_frowning_face:

Hi, I think the problem is that your superdirt is out of date. You should be able to upgrade it to the latest via the Quarks menu in supercollider.

Hi, thanks for this. I updated the directory, still no sound. I've updated SC too, to version 3.11.2. It seems like Atom and SC aren't communicating. When I quit SC, Atom doesn't report an error at all when I try to run a phrase, everything seems to run normally except for not producing a sound.

I've updated the Atom plug in just now, which gives a bit more of a report of what's going on on startup:

Choose **ghc** base path > no custom path configured *** use ghcup default path**

Ghci command: /Users/mpd3/.ghcup/bin/ghci Ghc-pkg command: /Users/mpd3/.ghcup/bin/ghc-pkg

Choose **BootTidal.hs** path > no custom path configured > not found in current directory *** found in the tidal installation folder** * load BootTidal.hs from /Users/mpd3/.cabal/share/x86_64-osx-ghc-8.10.5/tidal-1.7.8/BootTidal.hs

t> Loaded package environment from /Users/mpd3/.ghc/x86_64-darwin-8.10.5/environments/default

t>

t> [TidalCycles version 1.7.8] Installed in /Users/mpd3/.cabal/store/ghc-8.10.5/tdl-1.7.8-fcec090f/share Listening for external controls on 127.0.0.1:6010

Thanks again for your insight!

I enabled SuperDirt Autostart in the Atom plug in, and when I try and evaluate a phrase I get the following error in Atom:

'sclang' could not be spawned. Is it installed and on your path? If so please open an issue on the package spawning the process.

Maybe this helps? Thanks in advance!

That's because you have to add sclang to your $PATH. The how to is here: supercollider/README_MACOS.md at develop · supercollider/supercollider · GitHub

Don't know why this doesn't come out of the box on macosx

Hi, thanks for this.
I made a shell script file, but where should I put it so that tidal and Atom can find it? And what should I call it?

The atom plugin will execute sclang as your terminal would do. So it will work when you're able to execute sclang from your terminal

Hi,
Thanks again for the help here. It still doesn't seem to work. When I boot sclang from the terminal, I get the same readouts in the console as I get in SC, but still no sound.
Thanks in advance for any further clues.

It's very possible that supercollider is failing to upgrade superdirt. This can happen if you have changed any files in the SuperDirt folder.

You could try this:

cd ~/Library/Application\ Support/SuperCollider/downloaded-quarks/SuperDirt
git stash
git pull https://github.com/musikinformatik/superdirt.git
git checkout develop

Then restart supercollider or do 'recompile class library' before restarting superdirt.

1 Like

Thanks Alex, that seems to have done the trick! :raised_hands:t2::1st_place_medal::trophy:

1 Like