Superdirt start trouble?

hello all. still fairly new at this. I've been messing around for a couple months off and on w Tidal Cycles and really enjoying it. Last night I updated it and had some success after 2 hours or so of frustration. Today, however, when opening Supercollider and Atom I am stuck again, no sound happening and seemingly none of my particular issues found in any of the existing help topics/threads...

This is Supercollider after starting it up and running SuperDirt.start :

compiling class library...
GVA info: Successfully connected to the Intel plugin, offline Gen95
Found 836 primitives.
Compiling directory '/Applications/'
Compiling directory '/Users/matthomefolder/Library/Application Support/SuperCollider/Extensions'
Compiling directory '/Users/matthomefolder/Library/Application Support/SuperCollider/downloaded-quarks/Vowel'
Compiling directory '/Users/matthomefolder/Library/Application Support/SuperCollider/downloaded-quarks/Dirt-Samples'
Compiling directory '/Users/matthomefolder/Library/Application Support/SuperCollider/downloaded-quarks/SuperDirt'
Compiling directory '/Users/matthomefolder/Library/Application Support/SuperCollider/downloaded-quarks/Automation'
Compiling directory '/Users/matthomefolder/Library/Application Support/SuperCollider/downloaded-quarks/Bjorklund'
numentries = 1272901 / 19880512 = 0.064
5861 method selectors, 3392 classes
method table size 21015384 bytes, big table size 159044096
Number of Symbols 15040
Byte Code Size 448230
compiled 562 files in 0.52 seconds
compile done
localhost : setting clientID to 0.
internal : setting clientID to 0.
Class tree inited in 0.01 seconds

*** Welcome to SuperCollider 3.10.3. *** For help press Cmd-D.
SCDoc: Indexing help-files...
SCDoc: Indexed 1934 documents in 0.83 seconds
-> SuperDirt
Booting server 'localhost' on address
Found 0 LADSPA plugins
Number of Devices: 3
0 : "Built-in Microph"
1 : "Built-in Output"
2 : "Duet USB"

"Duet USB" Input Device
Streams: 1
0 channels 2

"Duet USB" Output Device
Streams: 1
0 channels 4

SC_AudioDriver: sample rate = 44100.000000, driver's block size = 512
Exception in World_OpenUDP: bind: Address already in use
Server 'localhost' exited with exit code 1.

and this is Atom after booting the Tidal package:
Choose ghcup default path: /Users/matthomefolder/.ghcup/bin

Ghci command: /Users/matthomefolder/.ghcup/bin/ghci Ghc-pkg command: /Users/matthomefolder/.ghcup/bin/ghc-pkg

Load BootTidal.hs from /Users/matthomefolder/.atom/packages/tidalcycles/lib/BootTidal.hs

t>Loaded package environment from /Users/matthomefolder/.ghc/x86_64-darwin-8.8.3/environments/default


t>Listening for controls on

any thoughts! I had it all running before quitting last night.



Hi Matt,

Yes, it happens sometimes if tidal or SuperCollider was not stopped properly.
The important piece of information here is : Exception in World_OpenUDP: bind: Address already in use
Which means, some process (most likely zombie tidal process) is taking your listening port 57120 and has not released it yet.
The solution to that problem is (most likely) to execute that in SuperCollide (before restarting Tidal):


That should do it, also rebooted supercollider after that would help.
If it is still not working after that, try to find which process is using tidal port.



Hi artheist,

thank you, great to know. I was just now replying that I actually did the old "turning it off and on again", if you can believe it, which sorted it out for me. I will try and remember the command you suggested if I run into this again. I appreciate it!


Yes, that is the last resort.

thanks again. your response confirmed to me my suspicion that the "already in use" line was the crux of it.



Yes, it happens to me quite often, since I often lock my session and come back to Tidal and/or SC without having properly wrapped my livecode session (sometimes with tidal still sending events), so most of the time the Server.killAll; does the job, but oftentimes I need to restart Tidal and SC properly.
However, full laptop reboot is only needed if I messed up with my audio really badly (meaning having multiple DAWs still open + audio in browser + plug and play audio interfaces) but this usually lies on the OS level not application. Hope that helps