Tidal on Raspberry Pi 4 with Ubuntu?

This is really good to know, as ansible seems not to be an option for windows. I will send the link to anyone in trouble, thank you!

1 Like

Hey @renzo.rospigliosi, I know you mentioned you're using Ubuntu, so I don't know if this is much help, but I was able to get Tidalcycles going on Raspbian by following the install directions on the Tidalcycles page.

Except when I installed Supercollider, I used the sudo command, and I used Vscode (headmelted)

I'm booting off a SSD and it runs pretty smoothly.

Oh I wanna try that too! Thank you

Can you give me instructions on how to install tidal cycles on raSpberry pi

TidalCycles stopped working for me on Raspberry Pi Raspbian. I tried @cleary's method above and the installation was smooth.

But when I try to start SuperDirt on supercollider, it says:

Found 0 LADSPA plugins
could not initialize audio

Any idea for a fix? Been Googling.

Thanks!

Johnny

Have you got Jack installed/started?

I like to use qjackctl...

I have it installed, but when I run qjackctl in the terminal it says

bash: qjackctl: command not found

You'll need to install qjackctl too - it's a separate package,a gui frontend to JACK

Thanks @cleary! I have it installed, but when I click start I get an error. It says "Could not connect to JACK server as client"

Any ideas? I tried Googling it, but can't seem to find anything.

No idea from here - have you mucked about with the default JACK config at all?

It's usually a matter of just kicking it off from qjackctl, and it will default to your onboard audio hardware for inputs/outputs. For external devices you might need to muck about with the settings a little but...

Depending on how bespoke your setup is already, it's probably worth your while just nuking this install, go back to fresh, install jackd and qjackctl and make sure they're working, then run my installer and bob is ( or should be) your uncle

Doing a fresh OS install got Supercollider going! I didn't even have to tweak JACK at all. I'm not sure what the issue was before because it was a new install when I first tried. But now when I try to run a line of code on VSCODE it says:

Getting token failed: Error: The name org.freedesktop.secrets was not provided by any .service files

this is because it's missing a keyring provider I think, try installing gnome-keyring

Thanks, @cleary. I think I just gotta tinker with it a bit more. I got supercollider and vscode to work, but now when I run code, there's no audio. There doesn't appear to be any errors.

1 Like

No worries, I'm flying blind here without (haven't ever got it running on a pi) so I'll let you tinker further - post back when you've got it sorted, it'd be useful for anyone else :slight_smile: