[ARCH] Noob error: Couldn't set realtime scheduling priority 1

So I'm getting this output when I run sclang:

Info: 4 methods are currently overwritten by extensions. To see which, execute:
MethodOverride.printAll

compile done
localhost : setting clientID to 0.
internal : setting clientID to 0.
Couldn't set realtime scheduling priority 1: Operation not permitted
Class tree inited in 0.01 seconds


*** Welcome to SuperCollider 3.12.2. *** For help type ctrl-c ctrl-h (Emacs) or :SChelp (vim) or ctrl-U (sced/gedit).
Couldn't set realtime scheduling priority 1: Operation not permitted
sc3>

I played around with the qjackctl app to see what worked but still no idea what I'm looking for or what to fiddle around with. I run sclang again when jack is running but I get the same error.

I'm usually good at figuring this kind of thing out, and I've been able to fix every error in programs when they pop up, but not this one.

I appreciate any input

This is because you aren't using a real-time scheduler in your kernel.

This will probably help:
https://wiki.archlinux.org/title/Realtime_kernel_patchset

1 Like

Thanks, I added the kernel and updated using -Syyu.

I don't see any changes sadly. No sound. Etc.

I get the same errors. Is there anything I should change in a file or something so that the scheduling priority is modified?

Also: any idea on what the qjackctl settings should be?

Sorry I'm not familiar enough with arch tomknow how they do their kernel management.

No sound/Qjackctl is a different matter though - this error shouldn't affect whether or not you get sound.

In Qjackctl you need to tell it what device you want to output sound to (default is usually a good guess), then start the JACK server.
Once JACK is running, start supercollider and make sure it appears in the JACK connections dialog, and is outputting to the device you specified (should have a line running from sc on the left to the device on right)

@defnlife In terms of realtime scheduling on arch, I ran into the same problem when installing recently. This article helped me set it up properly (with Jack).

Hope it helps!