Atom Not Opening on Mac 10.13.6

Hey guys,

Got an issue I can't explain.
I couldn't quit Atom, so I chose to Force Quit the app instead. Now it doesn't open at all - as if it doesn't exist.

The image shows the package contents but that's as far as I'm able to discover & I have made sure all of the pre-requisites are in place etc. etc.

Any help or ideas on this would be awesome! Cheers!

1 Like

I think you played bad with the atom configuration.
Open the file ~/.atom/config.cson and remove the bootTidalPath: row

Ok well the issue is, is that I can't actually enter the Terminal window to edit it out . . . and I can't find that ~/.atom/config.cson file in any case. Perhaps something broke when I Force Quit the app??

Thanks in advance @ndr_brt

My advice is, close everything, remove atom, remove ~/.atom folder, then reinstall atom and reinstall tidalcycles plugin

Still not luck unfortunately!

what if you start atom from the terminal? same error as before?

Yup same as before! :smile:

Lowercase it.

Nope still no window showing. Been looking around and wondering if the 'complete path' on terminal should be different . . . ? Seen as Atom worked with the 'Stack' rather than 'Cabal' previously . . .

Atom is independent from cabal or stack

As said on github, there's a problem with your ghc installation, I'm not able to help you, sorry, but maybe someone here can.