BIG Error In Tidal Cycles


It has taking me 1 week so far to install Tidal Cycles. It is the most difficult thing I have ever tried on a computer. I have a MacBook Air M1 with Monterey 12.2.1

After tons of errors: Can’t locate Quarks, Haskell Ghci errors, SuperDirt error, Output errors, Multiple file errors and more now I seem to have only one error left!

Please help me with this one and would be so thankful and gonna make so good stuff in return!

Choose ghc base path
> no custom path configured
***** use ghcup default path****

Ghci command: /Users/mindator/.ghcup/bin/ghci Ghc-pkg command: /Users/mindator/.ghcup/bin/ghc-pkg

Start atom-tidalcycles plugin

Choose BootTidal.hs path
***** custom path configured****
*** load BootTidal.hs from /Users/mindator/.atom/packages/tidalcycles/lib/BootTidal.hs**



t> : error: Could not find module ‘Sound.Tidal.Context’ It is not a module in the current program, or in any known package.

I have SuperCollider Installed, Tidal Cycles Installed, Quarks installed, SuperDirt Installed, Haskell installed, Ghci installed, Output working but:

t> : error: Could not find module ‘Sound.Tidal.Context’ It is not a module in the current program, or in any known package.

Please help me with this and I would be the luckiest man in the planet!


Here is inside my ghcup folder:

cabal haskell-language-server-wrapper-
cabal- hp2ps
ghc hp2ps-8.10
ghc-8.10 hp2ps-8.10.7
ghc-8.10.7 hpc
ghc-pkg hpc-8.10
ghc-pkg-8.10 hpc-8.10.7
ghc-pkg-8.10.7 hsc2hs
ghci hsc2hs-8.10
ghci-8.10 hsc2hs-8.10.7
ghci-8.10.7 runghc
ghcup runghc-8.10
haddock runghc-8.10.7
haddock-8.10 runhaskell
haddock-8.10.7 runhaskell-8.10
haskell-language-server-8.10.7 runhaskell-8.10.7
haskell-language-server-8.10.7~ stack
haskell-language-server-wrapper stack-2.7.3

I think I have it installed now.

I was installing LLVM 3 times for it to work. You need 6 programs to install Tidal Cycles.

Why is this nothing about the importance of LLVM in the TidalCycles installation instructions?
Anyway this installation is the most horrible thing ever.. Killed alot of my creativity. To the creator: I hope you read this because this is so bad.

So sorry you've been having problems. I think the M1 has introduced a few changes - nothing has depended on LLVM before. If you have found a way to get things working maybe you could add a new section to the installation instructions yourself? This may surprise you but I don't think too many people have access to M1 Macs yet so unfortunately it's hard to test out.

On new mac M1 TidalCycles gives an error related to LLVM as reported in this post >> Trouble installing Tidal library - MacOS Big Sur (Failed to build... Warning: Couldn't figure out LLVM version...)
Installing the latest version of LLVM fixes the problem and allows you to complete the installation. I have no idea why LLVM interferes with TidalCycles installation.

Sorry for my bitter tone before but man that was annoying. Maybe change the installation manual on the main website? Cus it is super miss-leading and I guarantee more people gonna have this problem in the future.

I solved the same problem.
if you solved it yet, please try this.
I use GHC 8.10.7 and llvm 12.
I have a MacBook Pro M1-Max with Monterey 12.2.1