Cabal not installing

While running "choco install tidalcycles" on Win 10 I had a power outage. I re-ran the installer, but am getting hung at:

Extracting C:\Users<user dir>\AppData\Local\Temp\chocolatey\cabal\\ to C:\ProgramData\chocolatey\lib\cabal\tools\cabal-
Chocolatey timed out waiting for the command to finish. The timeout
specified (or the default value) was '2700' seconds. Perhaps try a
higher --execution-timeout? See choco -h for details.
The install of cabal was NOT successful.
Error while running 'C:\ProgramData\chocolatey\lib\cabal\tools\chocolateyInstall.ps1'.
See log for details.

I tried running choco uninstall tidalcycles and re-reunning the install with the same results.

SuperDirt installs correctly and starts
Atom installed correctly and starts
the error within Atom is:
t> : error:
Could not find module `Sound.Tidal.Context'
It is not a module in the current program, or in any known package.
t> Variable not in scope: d1 :: t0 -> t

Variable not in scope: s :: t1 -> t0


things I've tried:

  • extract the file manually, launch it.
  • delete the file, re-run the installer
  • go to "C:\ProgramDatca\chocolatey\lib\cabal\tools\cabal-", launch the file

none of these have had success

so, what worked was:
regedit. search for "cabal" delete every instance of a cabal key. 2 keys would not delete.
search C:\ for "cabal" Delete every instance of it (4 were found)

re-run choco install tidalcycles.


Hi, it seems that cabal has installed but the tidal library hasn't. Try running this from the commandline: cabal install tidal --lib