Cannot install on mac

hello. i will post again because i have more than one picture and this forum will not let me post my pics as a new user

hello. i am trying to install tidal on my mac m1 with Ventura 13.0 (22A380)

i tried to use the auto install instrauctions for macos, but I have some problems.

my supercolider server seems to work just fine

however, when i use the tidalcycles package in Atom, i have a package error.

error message in entirety:
Uncaught Error: Cannot call write after a stream was destroyed

Hide Stack Trace
Error [ERR_STREAM_DESTROYED] [ERR_STREAM_DESTROYED]: Cannot call write after a stream was destroyed
at doWrite (_stream_writable.js:431:19)
at writeOrBuffer (_stream_writable.js:419:5)
at Socket.Writable.write (_stream_writable.js:309:11)
at Process.writeLine (/Users/kidist/.atom/packages/tidalcycles/lib/process.js:53:24)
at REPL.tidalSendLine (/Users/kidist/.atom/packages/tidalcycles/lib/repl.js:78:15)
at REPL.tidalSendExpression (/Users/kidist/.atom/packages/tidalcycles/lib/repl.js:69:10)
at /Users/kidist/.atom/packages/tidalcycles/lib/repl.js:95:14
at Array.forEach ()
at REPL._eval (/Users/kidist/.atom/packages/tidalcycles/lib/repl.js:87:8)
at HTMLElement.tidalcyclesEvalMultiLine (/Users/kidist/.atom/packages/tidalcycles/lib/tidalcycles.js:72:56)
at CommandRegistry.handleCommandEvent (/Applications/
at KeymapManager.dispatchCommandEvent (/Applications/
at KeymapManager.handleKeyboardEvent (/Applications/
at WindowEventHandler.handleDocumentKeyEvent (/Applications/

I tried installing according to this tutorial . I got to the step about cd'ing into Dirt and ussing the Makefile to compile, however I have this libsndfile error.

(as a new user, these post too quickly errors are also a bit annoying oof)

this is rather frustrating becasue I already have libsndfile downloaded as you can see here. It is "already installed and up-to-date"

let me know if you need more info!

I don't have the knowledge to help you out but I want to commend you on the level of details provided! This should hopefully enable someone to help you out. Great post!

1 Like

That tutorial is maybe a decade old and is getting you to install 'classic dirt' which is not really used any more. Best ignore that one!

It looks like you have the atom plugin and superdirt installed fine. It's just the tidal haskell library itself (the core pattern 'engine') which is having problems for some reason.

You can clear out the haskell install with this command from a terminal window. It's a bit dangerous so be careful when copying and pasting not to insert any extra spaces.

rm -rf ~/.ghc ~/.cabal

Once you've done that you can try installing the library afresh:

cabal update
cabal v1-install tidal

If that doesn't work you might need to do this first (including the leading '.'):

. ~/.ghcup/env

If that doesn't work, maybe haskell itself didn't install properly. That looks like it might be the case for you. You can install it by following the instructions here: GHCup


thank you so much! reinstalling tidal did the trick.

1 Like