Changing bps/bpm of cycles

Hi,
Thanks for organizing this course !

I’m trying to change the bps of my cycles (following this video tutorial https://youtu.be/plu04_ewZUQ) on atom. To do so, I run the line

bps 1.5

However Tidal answers by

• Variable not in scope: bps :: Integer -> t
• Perhaps you meant one of these:
    ‘bpf’ (imported from Sound.Tidal.Context),
    ‘bpq’ (imported from Sound.Tidal.Context),
    ‘cps’ (imported from Sound.Tidal.Context)

and nothing changes.

Is this command outdated ? What am I doing wrong ?

I’m using a slightly older version, but I believe you want to use “setcps” for this

1 Like

Yes, setcps is the one

2 Likes

Since we’re are at it, I was assuming that default cps was 1, right ? but every time I open atom, things seems to be running at something which is rather close to 0.6 or 0.55. Is it possible that I accidentally messed up with some settings ?
Also every time I evaluate a setcps, supercollider posts “no synth or sample named ‘nil’ could be found.module ‘sound’: instrument not found: nil”, but I don’t know if this is relevant at all (cps correctly updated though).

Hi Leon,

The default cps used to be 1. If you have 2 beats per cycle, that’s 120 beats per minute. I noticed a lot of people didn’t think about changing from the default, and after listening to a lot of 120bpm and 60bpm performances, I changed the default to 0.5625, i.e. 135bpm, the equivalent of fairly fast techno.

2 Likes

That supercollider warning is a known bug, it doesn’t really do any harm but I should fix it soon.

Ok thanks good to know ! So you were tired of people doing slower music, and you hit the arch meta fast fuction :grinning:

Yes, maybe we should change the bpm every tidal release, to give a different flavour :slight_smile: Any nominations?

… actually I think that wouldn’t be considerate, I noticed the change surprised a lot of people, a bit disconcerting to suddenly feel time speed up and not know why!.

1 Like

Can this be added to the tutorial under Tempo? https://tidalcycles.org/index.php/Tutorial I’ve always wondered what the default cps was!

I tried adding it myself but I don’t have the right permissions.

It’s not clear but you can edit after creating an account -> https://tidalcycles.org/index.php?title=Special:UserLogin&returnto=Tutorial&returntoquery=action%3Dedit

1 Like