D1 $ sound "bd" doesn't sound

OS : Windows 10
Editor : VSCode
GHCI : 9.0.2
SuperColider : 3.12.2
SC3plugins : 3.11.1
TidalCycles : 1.7.10 ( installed by stack )

Hi, there.
I am trying to start a tidal cycle and have just completed the installation.
The installation did not encounter any errors and seems to have completed without problems.
However, after starting SuperColider and SuperDirt, the following code on test.tidal in Editor did not sound.

d1 $ sound "bd"

The following output was obtained

Evals: 1 GHCi, version 9.0.2: https://www.haskell.org/ghc/  :? for help
Loaded GHCi configuration from C:\Users\[myname]\AppData\Local\Temp\haskell-stack-ghci\2a3bbd58\ghci-script
ghci> ghci> [TidalCycles version 1.7.10]
Installed in C:\sr\snapshots\4735ed14\share\x86_64-windows-ghc-9.0.2\tidal-1.7.10
Listening for external controls on
tidal> tidal> Evals: 2 tidal> Evals: 3 tidal> Evals: 4 

When SuperCollider is terminated in this state, the following message is obtained.

Waiting for SuperDirt (v.1.7.2 or higher)..

Do you know of a solution?

VSCode Settings

"tidalcycles.ghciPath": "ghci",
"tidalcycles.useStackGhci": true,

Have you installed the SuperDirt quark in Super collider? Did you start it in SC with "SuperDirt.start" ?

Thank you for replying, Mr. Squim.
Yes, I had installed SuperDirt by bellow code.

Quarks.checkForUpdates(); Quarks.install("SuperDirt", "v1.0")

And, I had added start code in my SuperCollider startup file.
I have confirmed that the following message appears when SuperCollider is started.

SuperDirt: listening to Tidal on port 57120

Add the startup file (it's a copy and paste of the official tutorial).

This is an example startup file. You can load it from your startup file
(to be found in Platform.userAppSupportDir +/+ "startup.scd")

s.reboot { // server options are only updated on reboot
    // configure the sound server: here you could add hardware specific options
    // see http://doc.sccode.org/Classes/ServerOptions.html
    s.options.numBuffers = 1024 * 256; // increase this if you need to load more samples
    s.options.memSize = 8192 * 32; // increase this if you get "alloc failed" messages
    s.options.numWireBufs = 64; // increase this if you get "exceeded number of interconnect buffers" messages
    s.options.maxNodes = 1024 * 32; // increase this if you are getting drop outs and the message "too many nodes"
    s.options.numOutputBusChannels = 2; // set this to your hardware output channel size, if necessary
    s.options.numInputBusChannels = 2; // set this to your hardware output channel size, if necessary
    // boot the server and start SuperDirt
    s.waitForBoot {
        ~dirt = SuperDirt(2, s); // two output channels, increase if you want to pan across more channels
        ~dirt.loadSoundFiles;   // load samples (path containing a wildcard can be passed in)
        // for example: ~dirt.loadSoundFiles("/Users/myUserName/Dirt/samples/*");
        // s.sync; // optionally: wait for samples to be read
        ~dirt.start(57120, 0 ! 12);   // start listening on port 57120, create two busses each sending audio to channel 0

        // optional, needed for convenient access from sclang:
            ~d1 = ~dirt.orbits[0]; ~d2 = ~dirt.orbits[1]; ~d3 = ~dirt.orbits[2];
            ~d4 = ~dirt.orbits[3]; ~d5 = ~dirt.orbits[4]; ~d6 = ~dirt.orbits[5];
            ~d7 = ~dirt.orbits[6]; ~d8 = ~dirt.orbits[7]; ~d9 = ~dirt.orbits[8];
            ~d10 = ~dirt.orbits[9]; ~d11 = ~dirt.orbits[10]; ~d12 = ~dirt.orbits[11];

    s.latency = 0.3; // increase this if you get "late" messages

That's a very old version of superdirt - it's up to 1.7.3:

Try changing your version number and rerunning

1 Like

Thank you for replying Mr. cleary.

I had done bellow code in SuperCollider and program had been solved.

Quarks.install("SuperDirt", "v1.7.3")

Thank you for your corporation.