Does "timescale" for anyone else?

I've tried using the # timescale function but I'm not able to get it to actually stretch out a sample.

I tried the example from the docs

d1 $ slow 2 $ s "breaks152" # legato 1 # timescale (152/130) # cps (130/60/4)

but the sample plays at normal speed and then end early. In fact no value I give the function seems to have any effect on the sound. Is there something I need to set in BootTidal.hs or in Supercollider options?

For reference I'm using Tidal 1.9.5 and Supercollider 3.13.0 on Linux

Here it works fine. In SuperCollider you can run (type:\dirt, s:\hh, timescale:5).play and see if it works on that side.

What version of SuperDirt do you have? You can check it with running Quarks.gui in sclang.

That was it, I was on 1.7.1 and needed 1.7.3. I'd figured it was something like this but didn't know where to look, thanks so much

1 Like