Downgrade on arch

Hi, I've found that my old loop did'not play well with the newest version of tidal. On my system is tidal installed by official package: haskell-tidal. I've tried the downgrade script but with no success (some Haskell hell if I've to be precise). Then i have tried installing with cabal (I have to install it first, it is not preliminary to run tidal on arch), succesfully installed tidal-1.7.10 to ~/.cabal/bin but that's all I have achieved in this context.
running ~/.cabal/bin/tidal is this:

[TidalCycles version 1.7.10]
Installed in /home/paum/.cabal/store/ghc-9.0.2/tidal-1.7.10-ccc71f217839abb092671cfef5662690abcd6c18fea6207d1062dd38ca75d90d/share
Listening for external controls on 

and running globally installed tidal runs within ghci environment:

GHCi, version 9.0.2:  :? for help
[TidalCycles version 1.9.4]
Installed in /usr/share/haskell-tidal
Listening for external controls on

I am an Emacs user, and it would be cool to be able decide within emacs, which tidal version I want to run.
Thanks for any help.

I think you want to switch the ghc version (and that switches the tidal version, to whatever you have cabal-installed for that specific ghc).

So you could set PATH to point to the directory containing ghci and ghc-pkg - before starting emacs.

If you want to switch while emacs is running, then modify emacs variable exec-path? (Subprocess Creation (GNU Emacs Lisp Reference Manual) ) (I have not done this)

Separately, what is "old loop did'not play well with the newest version" exactly? Perhaps it's a regression in tidal - that could be fixed. Or, your "old loop" could be modified. Does the changelog (Changelog for tidal-1.9.4 | Hackage) give a hint?

Hi @jwaldmann ! Actually yes, my 2 years old loop (the same, I am sure,I have checked it many times) chooses the samples a little bit different way, so sounds different. Thanks for advicig me to the changelog, probably something has changed.

About the PATH thing, I will investigate further. thanks