finally installed 1.9.2 on my windows 10 machine

I finally installed 1.9.2 on my windows 10 machine but it has been a bumpy ride :wink:
So i thought i would share my experience to maybe help some other windows 10 users.
Best thing you can do before you begin is create a system restore point so you can always go back.

Okay, first i was still on Tidal 1.7.something because i've had some bad experiences upgrading in the past.
But after many failed attempts this is what worked for me.

Assuming you are only using everything for Tidal, delete/uninstall (search harddrive to delete folders) everything related to ghc, cabal and tidal.
Open powershell as admin and i use the following commands:

  • installed ghcup
Set-ExecutionPolicy Bypass -Scope Process -Force;[System.Net.ServicePointManager]::SecurityProtocol = [System.Net.ServicePointManager]::SecurityProtocol -bor 3072;Invoke-Command -ScriptBlock ([ScriptBlock]::Create((Invoke-WebRequest -UseBasicParsing))) -ArgumentList $true
  • installed ghc 9.4.2
    ghcup install ghc 9.4.2

  • set ghc 9.4.2 as default
    ghcup set ghc 9.4.2

  • installed cabal
    ghcup install cabal

Here's where i went a bit different because the normal cabal update/install wasn't working.
Everything installed without a problem but tidal wasn't found when starting (Could not find module `Sound.Tidal.Context).

So i used:

  • updating Cabal
    cabal new-update

  • installed Tidal
    cabal new-install --lib tidal

I'm not sure what's going on under the hood but after the installation was done, Tidal was working but not producing any sound.
I saw in another post that Alex mentioned to delete the Superdirt folder and clone the repository so i did.

delete Superdirt folder
git clone
cd .\SuperDirt\
git checkout v1.7.2

And after a few night of me repeatedy asking my laptop why it is not working, there was sound.


Thanks for sharing this!

One day we will get that easy drag-and-drop install process working..

(btw just edited your post to fix some formatting issues with the commands)

Thank you so much this is the one thing that worked after a long period of trying <333

1 Like

Hey also team, if it looks like atom isnt reading ghci. Or if it still doesnt work after the above fix,, changing the permissions for ghci in command prompt worked for me :))
Love y'all, never give up trying to install!!

"Try running GHCI with system administrator permissions (type "Command Pro..." into Start and click "Run as administrator"). If ghci now works then the problem was solved because you now have access to the file c:\Windows\System32\pthread.dll.

To use ghci without Admin permissions (recommended), change the permissions (while you have admin permissions) so that user can read the pthread.dll file:

C:\> CACLS c:\Windows\System32\pthread.dll /e /p your-username:r

(replace your-username with your actual username)

Credit for this fix goes to this post: CS 3040: Installing Glasgow Haskell Compiler"

Source: haskell - ghci on Windows 10 error: user specified .o/.so/.DLL could not be loaded (addDLL: pthread - Stack Overflow

1 Like