GHCup install fails on intel macOS - ideas?

Hi! I'm on macOS Monterey, using intel core.
I have tried uninstalling (ghcup nuke, removed xcode's command line tools, removed .ghc, .cabal and .ghcup folders).
Reinstalled xcode-select and now GHC in hope of updating my tidal configuration using the bootstrap.


[ Info  ] verifying digest of: ghc-9.2.5-x86_64-apple-darwin.tar.xz
[ Info  ] Unpacking: ghc-9.2.5-x86_64-apple-darwin.tar.xz to /Users/santamaraton/.ghcup/tmp/ghcup-4564b81e02834807
[ Info  ] Installing GHC (this may take a while)
[ ghc-configure ] dyld[13015]: Library not loaded: '/usr/local/opt/re...
[ ghc-configure ]   Referenced from: '/usr/local/Cellar/gawk/4.1.3_1/...
[ ghc-configure ]   Reason: tried: '/usr/local/opt/readline/lib/libre...
[ ghc-configure ] ./config.status: line 930: 13014 Done(141)         ...
[ ghc-configure ]      13015 Abort trap: 6           | $AWK -f "$ac_t...
[ ghc-configure ] config.status: error: could not create mk/
[ Error ] [GHCup-00841] Process "sh" with arguments ["./configure",
[ ...   ]                              "--prefix=/Users/santamaraton/.ghcup/ghc/9.2.5",
[ ...   ]                              "--disable-ld-override"] failed with exit code 1.
[ Error ] Also check the logs in /Users/santamaraton/.ghcup/logs
"ghcup --metadata-fetching-mode=Strict --cache install ghc recommended" failed!```

Okay, I got further after reinstalling (along with a brew cleanup of) gawk. Now the install ends on the following note:

Installing cabal
[ Info  ] Cabal installation successful
sh: line 119: cabal: command not found
"cabal update --ignore-project" failed!```

and then, after brew installing ghc and cabal, it all works out!