Haskell install issues - sSL certificate

Hello everyone,

i'd love to pick up tidal again after some time learning the basics of sc, but am running into obscure install issues (to me) on mac os. Seems to be perhaps about curl certificates and haskell but i couldn't find a solution in forums thus far. Here's how terminal responds to the general install command on tidalcycles.org:

users-macbook-pro:~ maxlouisraugel$ curl https://raw.githubusercontent.com/tidalcycles/tidal-bootstrap/master/tidal-bootstrap.command -sSf | sh
Detected system information:
Architecture: x86_64
sh: line 64: command_exists: command not found
Distribution: Darwin
sh: line 64: command_exists: command not found
Distro alias: darwin
sh: line 104: command_exists: command not found
Distro version: 17.7.0
sh: line 64: command_exists: command not found
[1] 'git' command already installed.
[2] Installing Haskell (via 'ghcup')...
curl: (60) SSL certificate problem: certificate has expired
More details here: curl - SSL CA Certificates

curl performs SSL certificate verification by default, using a "bundle"
of Certificate Authority (CA) public keys (CA certs). If the default
bundle file isn't adequate, you can specify an alternate file
using the --cacert option.
If this HTTPS server uses a certificate signed by a CA represented in
the bundle, the certificate verification probably failed due to a
problem with the certificate (it might be expired, or the name might
not match the domain name in the URL).
If you'd like to turn off curl's verification of the certificate, use
the -k (or --insecure) option.
HTTPS-proxy has similar options --proxy-cacert and --proxy-insecure.
grep: /Users/maxlouisraugel/.bashrc: No such file or directory
sh: line 210: [: -ne: unary operator expected
[3] Congratulations, you have all the pre-reqs...
Installing tidalcycles haskell library (via cabal)...

sh: line 220: /Users/maxlouisraugel/.ghcup/env: No such file or directory
users-macbook-pro:~ maxlouisraugel$

I have tried the -k or --insecure options to no avail...

thanks in advance for any help

Hi, I think this is a problem with a 'root certificate' expiring.

The first answer here should solve it for mac os:

If you're curious, there's more info here: DST Root CA X3 Expiration (September 2021) - Let's Encrypt

1 Like

thanks, that worked !

for anyone with the same issue you will then have to find the etc/... folder path.
In my case it was a hidden folder which I found an alias for in HD but i think the original is in HD/private (next to Applications, Library, Users) so you will need to:

  1. show hidden files - open the terminal, type defaults write com.apple.Finder AppleShowAllFiles true and enter
  2. Command+Shift+C to open the highermost directory -> go into your internal HD, and there you should find an alias for 'etc' or the 'private' folder which contains the original
  3. if you wish to hide again hidden files/folders: defaults write com.apple.Finder AppleShowAllFiles false
1 Like

Here's a quick and easy tip for hidden folders on the mac: in the Finder, just do shift command period to show/hide hidden files.

1 Like

oh yes i'd read about this, but unfortunately it doesn't work on my system.