Having Trouble Installing! (Mac)

Hi there! Mac user here, ran the bootstrap installer and everything seemed to be fine until I attempted to run d1 $ sound "bd sd" in Atom, which prompted the error:

t>/bin/sh: /Users/Nate/.ghcup/bin/ghci: No such file or directory

I found that someone had a similar problem, so I attempted to run ~/.ghcup/bin/ghci in Terminal but that didn't work. I attempted to then run the bootstrap installer again and noticed this error message:

"_eghcup --cache install ghc recommended" failed!

Here's the full Terminal dialogue in case there's anything helpful in here:

Nathans-MacBook-Pro:~ Nate$ curl https://tidalcycles.org/tidal-bootstrap.sh -sSf | sh
[0] Mac OS detected, moving forward with installation...
[1] git found, skipping...
[2] Installing Haskell (via 'ghcup')...

Welcome to Haskell!

This script will download and install the following binaries:

  • ghcup - The Haskell toolchain installer
    (for managing GHC/cabal versions)
  • ghc - The Glasgow Haskell Compiler
  • cabal - The Cabal build tool

ghcup installs only into the following directory,
which can be removed anytime:

% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 8345k 100 8345k 0 0 3717k 0 0:00:02 0:00:02 --:--:-- 3717k
[ Info ] Upgrading GHCup...
[ Warn ] No GHCup update available

System requirements
Note: On OS X, in the course of running ghcup you will be given a dialog box to install the command line tools. Accept and the requirements will be installed for you. You will then need to run the command again.

[ Info ] verifying digest of: ghc-8.8.4-x86_64-apple-darwin.tar.xz
[ Info ] Unpacking: ghc-8.8.4-x86_64-apple-darwin.tar.xz to /var/folders/3g/f30b7w211vzgpv5tb7qps7940000gn/T/ghcup-IqMgH1
dyld: lazy symbol binding failed: Symbol not found: _futimens
Referenced from: /Users/Nate/.ghcup/bin/ghcup (which was built for Mac OS X 10.13)
Expected in: /usr/lib/libSystem.B.dylib

dyld: Symbol not found: _futimens
Referenced from: /Users/Nate/.ghcup/bin/ghcup (which was built for Mac OS X 10.13)
Expected in: /usr/lib/libSystem.B.dylib

sh: line 35: 1740 Abort trap: 6 ghcup "$@"
"_eghcup --cache install ghc recommended" failed!
grep: /Users/Nate/.bashrc: No such file or directory
sh: line 37: [: -ne: unary operator expected
[3] Congratulations, you have all the pre-reqs...
Installing tidalcycles haskell library (via cabal)...

sh: line 48: cabal: command not found
sh: line 49: cabal: command not found
[4] Atom already installed, skipping...
[6] Installing atom TidalCycles plugin...
Installing tidalcycles to /Users/Nate/.atom/packages ✓
[7] SuperCollider already installed, skipping...
[8] Installing SuperCollider Plugins...
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 644 100 644 0 0 1096 0 --:--:-- --:--:-- --:--:-- 1095
100 6287k 100 6287k 0 0 2123k 0 0:00:02 0:00:02 --:--:-- 3685k
replace /Users/Nate/Library/Application Support/SuperCollider/Extensions/SC3plugins/AYUGens/AYUGens.html? [y]es, [n]o, [A]ll, [N]one, [r]ename: error: invalid response [{ENTER}]
replace /Users/Nate/Library/Application Support/SuperCollider/Extensions/SC3plugins/AYUGens/AYUGens.html? [y]es, [n]o, [A]ll, [N]one, [r]ename: error: invalid response [#### INST]
replace /Users/Nate/Library/Application Support/SuperCollider/Extensions/SC3plugins/AYUGens/AYUGens.html? [y]es, [n]o, [A]ll, [N]one, [r]ename: Nathans-MacBook-Pro:~ Nate$

Any advice is appreciated! Thanks so much :slight_smile:

Welcome, what version of macos are you running?

Hi there! Running Sierra 10.12.6.

Ok there are problems installing newer haskell on older versions of macos.

You could try installing the 8.6.3 version of the haskell platform from here:

and then running this from the commandline:

cabal v1-update; cabal v1-install tidal 

If that doesn't work, then try:

cabal update; cabal install tidal 

I've run the first command and tried making sound in Atom again- however I'm met with the same t>/bin/sh: /Users/Nate/.ghcup/bin/ghci: No such file or directory. Ran the second cabal command as well- Terminal tells me that everything is already installed, however.

~/.ghcup/bin/ghci run in Terminal also tells me No such file or directory. Thanks for your help so far :grinning:- any thoughts?

I think you need to go into the settings in atom, for the tidalcycles package.. Find the setting for ghci path and remove it (so it's an empty box). Then it should find ghci in the default location

Hey Alex- really appreciate all your help thus far. I've checked the tidalcycles package settings in Atom, however it already appeared to be empty. Received the same "no such file or directory" message upon trying to make sound again afterwards


Hm, what does this say, from a terminal window?

whereis ghci 

Doesn't seem to say anything- maybe something went wrong installing Haskell?

Yes maybe. But you installed that haskell platform version ok?

Yeah- it seemed like both the install and cabal update went fine. Didn't see any indication that something went wrong...

Hm, so how about this command: whereis cabal

Nothing again!


which cabal


ghci --version

ok! So I guess

which ghci



If so put /usr/local/bin in that ghci path setting and it should hopefully work!

hallelujah!! there's sound. thanks so much for all your help, truly appreciate it :slight_smile:

Great have fun !

Hi there, I'm trying to install tidal on macOS Catalina 10.15.7.

I pasted the easy install command line into terminal and all was fine until I saw this error:
[ Error ] DigestError "563253f54461f64f6e72864e9b955dd7a2bf2416c6d1855a1b60227bbcbbaea5" "e80a789e9d8cfb41dd87f3284b75432427c4461c1731d220d04ead8733ccdb5e"

[ Error ] Also check the logs in "/Users/lucypapadopoulos/.ghcup/logs"

"_eghcup --cache install ghc recommended" failed!

I read this post and thought maybe because I'm using an older Mac I need to download a later version of Haskell, so I did this and followed the rest of your instructions on this thread - entered command line which cabal, which ghci etc. Seemed to be a similar problem so I put /usr/local/binin that ghci path setting.

Still when I go on Supercollider and run SuperDirt.start it says -> nil at the bottom rather than listening to tidal. Any ideas?

Hi @lucyjp786,

Sorry about these problems :confused: I think MacOS Catalina is pretty new so the easy install should have worked fine.

Now that you've installed haskell separately though, and updated the atom package setting, what now happens when you try to start tidal in atom?

The supercollider problem would be a separate issue. Does it also give an error message, something like "Class not defined"? If so that means that SuperDirt hasn't installed properly. Running Quarks.install("SuperDirt") in supercollider should install it for you, it takes a while as it needs to download all the default samples.

If you still get problems please share all the output/error messages, even if they look meaningless there might be some clues. If there's a lot of it you could paste into https://pastebin.com/ and then share the link it gives you.