Having trouble with squiz

I'm using the vim-tidal plugin in neovim with Tidal v1.4.9 (and Supercollider 3.10.3) and I cannot get squiz to work.

d1 $ s "drum*4" # squiz "1 2 8 256" sounds the same as d1 $ s "drum*4"

I'm not sure what I'm missing. Any ideas?

Same configuration as yours and it works as expected, perhaps you're missing the sc3-plugins?

Yes this will be a problem with sc3plugins I think. You'll need to pick the version that matches with your supercollider version here https://github.com/supercollider/sc3-plugins/releases
and follow the instructions here as Mattia says https://supercollider.github.io/sc3-plugins/

Let us know if you have problems @silencer

I updated to the 13.10.0 version of SC3plugins, and it all works OK in Supercollider IDE when I run this:

x = {Squiz.ar(SinOsc.ar, MouseX.kr(1, 10, 1), zcperchunk: MouseY.kr(1, 10), mul:0.1).dup}.play(s);

restarted everything, but still no joy :slightly_frowning_face:

Hmm, any errors/warnings when you start superdirt?

No, everything looks normal there. I use the standard startup file and after loading all the samples etc. the last message in the Post window is SuperDirt: listening to Tidal on port 57120.

My guess is that you're on an older version of superdirt then, have a look in Language > Quarks in supercollider. Try selecting 'latest'

Yes. That's got it, thanks Alex... so many moving parts I didn't know about! Thank you. I saw you using it, and liked how it quickly made drums into bass-like sounds.

I'm working through the Cycle 0 workshops / teaching materials at the moment and hope to catch up soon. Even in the week 1 lessons, I've already learned new things – like pattern foot . and the @ operator. And it's helped clarify my understanding of * and \ in terms of density.

Great stuff!

1 Like

Good, and good to hear!