High noise on low sounds

Hey dear club!

There's a problem in TidalCycles that puzzles me for quite a while now:
When playing certain samples in TC, especially kicks, 808s or anything low I get some strange high overtones and I can't figure out why.

Here's an example of an 808 I just recorded:
https://vocaroo.com/1gEXCH5Om79P

1st is the original file (as played in Audacity)
2nd is the same sample as played in TC plus some # gain (close to clipping)
3rd is the sample played in TC without any # gain

Does anyone have a clue? Could it be due to some settings in SuperDirt/SuperCollider - or in how the VSCode plugin is integrated? Or is it maybe just something about my sound driver?
(I'll check on my other laptop / other interface if the issue persists.)

Thanks already in advance!

sorry for the lazy response:

  1. it's an audio issue so the problem will be on supercollider
  2. this is a common problem in audio engineering btw
  3. usually configuring the sound drivers / settings works
  4. try using ASIO4ALL if you're on Windows, it will solve the problem without having to do much other than change the server setting in SuperCollider and it will just generally work better.

btw i can't remember the name of this phenomenon (sub bass generating high pitch ringing) if anyone knows it pleaaase name it

1 Like

i remembered

this is a ringing artifact from aliasing

it may come from your settings or from audio conversion. like SuperCollider might be running in a different rate than your sound card or the original file itself and somn it's not doing a proper job in the conversion.

Thanks, @ritchse! That already helps a lot! Using ASIO4ALL instead of my dedicated soundcard driver actually does the trick.

Strange though that I don't get this kind of aliasing problem, when using Foobar or Audacity with that same audio driver. Must be some interplay between the driver and SuperCollider that causes it. I'll check if there's anything in SuperCollider's Server.default.options that I might need to adjust.

EDIT: Got it! It was actually my soundcard driver in SC not set to use ASIO, but MME. Sounds so much better now. :firecracker:

1 Like