How to install for M1 Mac

Ahh that makes more sense now, I'm getting some new bugs but feel like I'm moving forward thank you! So I got the SuperCollider IDE but when I boot the server I get a number of additional errors. A lot of them around a SC3Plugins folder like:

*** ERROR: dlopen '/Users/benzaiten/Library/Application Support/SuperCollider/Extensions/SC3plugins/HOAUGens/HOADecBinaural1_supernova.scx' err 'dlopen(/Users/benzaiten/Library/Application Support/SuperCollider/Extensions/SC3plugins/HOAUGens/HOADecBinaural1_supernova.scx, 0x0002): tried: '/Users/benzaiten/Library/Application Support/SuperCollider/Extensions/SC3plugins/HOAUGens/HOADecBinaural1_supernova.scx' (mach-o file, but is an incompatible architecture (have 'x86_64', need 'arm64')), '/System/Volumes/Preboot/Cryptexes/OS/Users/benzaiten/Library/Application Support/SuperCollider/Extensions/SC3plugins/HOAUGens/HOADecBinaural1_supernova.scx' (no such file), '/Users/benzaiten/Library/Application Support/SuperCollider/Extensions/SC3plugins/HOAUGens/HOADecBinaural1_supernova.scx' (mach-o file, but is an incompatible architecture (have 'x86_64', need 'arm64'))'

Now in my .tidal file the error is different now but probably better to get supercollider running before I start with these errors.

1 Like

I have not seen any errors with SC3Plugins, so I am at a loss. I have some suggestions, but hopefully someone else more knowledgable on SC and SCPlugins will respond.

With in the error message it says "(mach-o file, but is an incompatible architecture (have 'x86_64', need 'arm64'" This looks as if you have the wrong version of the files, but SC3plugins. It may be that the Tidal automated installer gives you the wrong files. You may want to reinstall the SC3plugins manually.

See: GitHub - supercollider/sc3-plugins: Community plugins for SuperCollider

The other thing to do is search this forum for similar error messages: "dlopen" or SC3-plugin error.

1 Like

Yup I did this, tried various things but couldn't get around the errors with my limited knowledge of the domain. I've tried now to run tidal and it seems to work though with some errors, like I notice some synths like superpiano or supersaw won't make any sound while supersquare and supermandolin do. At least I can play around for now with what's available. Thanks!

Hi. I'm installing Tidal Cycles in a M1 Mac Mini. I'm fairly new to SuperCollider.

I follow the guide, the installation is really confusing for Apple Silicon. Anyway, I'm getting successfully the test sound using Pulsar text editor. However, I'm getting this error in the Post window of SC:

FAILURE IN SERVER /n_run Node 1106 not found

How can resolve it? I lookup it u in the GitHub issues of SC but I got no results.

Many thanks

I don't know how to resolve this, but I get similar errors occasionally, sometimes they repeat with many nodes not found. So I quit server or kill all servers, then quit the SC IDE and restart. It usually clears it up, so I conclude that these are temporary system overloads, or memory faults. That is just an uninformed guess though.

Many thanks for the quick response. I'm trying to catch up with both SC and Tidal.

I'm running an M1 Mac mini with macOS Ventura 13.3.1

Apart from that error, I was getting errors with SC3 plugins, so, I followed the steps in order to clone, and replace the SC3 plugins, and at least for me , then restarting SC do the trick.

So, as 27th April 2023, the following steps I took to install SC and Tidal on an AS machine were (thanks for the installation article, and then the subsequents addendum of other users):

  • Install HomeBrew (I had already installed on my machine)
  • Automatic installation with Tidal BootStrap
    -That installed Pulsar (not Atom)
    -Had to reinstall GHCup. Went to the official website (cabal was not installed in the auto install)
  • Install Tidal lib with cabal.
  • I didn't have issues with SuperDirt (with auto install).

Then, I setup an startup.scd file with the script provided in the documentation of Tidal.

I tried Pulsar in order to troubleshoot first, but then I configure VSCode, installing Tidal (as per documentation provided also in Tidal). I got now VSCode working. I had to install Haskell syntax language extension in order to format the input text.

I followed the necessary steps to use Sublime as a text editor, but I had no luck.

I will update if I got luck with Sublime (that's my default text editor).

Thanks for sharing the details about your install results. It helps to know about it. Did you get an error message about cabal or ghcup during the bootstrap script execution?

No. It din’t give me any errors.

As other user above said about you’d specific question:

  • I had to install ghcup which wasn't installed by default in my machine
  • I couldn't run cabal after the tidal bootstrap install, only after installing cabal-install it worked

after various unsuccessful attempts, I successfully updated tidal my Mac Studio with Monterey 12.6.4 by following these steps:

  • update ghcup
    ghcup upgrade
  • remove homebrew from path as there is an incompatibility with llvm
    • PATH="~/.ghcup/bin:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin"
  • remove version 9.4.4 of ghc if you have already installed it
    ghcup rm ghc 9.4.4
  • remove also corresponding cabal store
    rm -rf .cabal/store/ghc-9.4.4
  • install ghc 9.4.4 with ghcup install ghc 9.4.4
  • set as default with
    ghcup set ghc 9.4.4
  • now update cabal cabal update
  • and install tidal with
    cabal install tidal --lib
  • now restore path with
  • tidal 1.9.4 should be installed correctly so you can
    • launch SuperCollider
    • start SuperDirt
    • launch Pulsar and boot tidal

There might be a simpler way, but this worked for me, at least to get the basics working. I'll need to spend more time on the rest of the configuration (midi, osc, ableton, reaktor...) but it will be for another day...

Hello everyone, i hope you're well.

I’ve been trying to install tidal on a new M1 MacBook running Sonoma and everything seems to work, but I am not getting any sound.

Supercollider works fine (running through Rosetta because I’m using plugins which aren’t yet built for silicon) and I’m getting sound there. Also if I try to play a non-existent sample in tidal, supercollider reacts with the usual error message so it seems they are communicating.

I'm with ghc 9.8.1 and tidal 1.9.4, both marked as installed. Let me know if you’ve experienced this or how I may troubleshoot this further. I’ve done one install with the website instructions and two more following barbe’s more specific M1 instructions linked in this thread (uninstalling / deleting folders between each).

Thank you for your time