Install Tidal > Windows > Automatic Installation, command invalid argument

Following the instructions for the automatic windows installation found at Windows | Tidal Cycles I am receiving an invalid argument.

Under step II - Installing Chocolatey: the package manager, upon pasting the command

 Set-ExecutionPolicy Bypass -Scope Process -Force; iex ((New-Object System.Net.WebClient).DownloadString(''))```

into powershell run as administrator and executing the following is returned:

Invoke-Expression : A positional parameter cannot be found that accepts argument '``'.
At line:1 char:52
+ ... ess -Force; iex ((New-Object System.Net.WebClient).DownloadString('ht ...
+                 ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : InvalidArgument: (:) [Invoke-Expression], ParameterBindingException
    + FullyQualifiedErrorId : PositionalParameterNotFound,Microsoft.PowerShell.Commands.InvokeExpressionCommand

I am attempting the install on a laptop factory defaulted and updated to Windows 10 Pro 20H2.

My searching so far has not led to an understanding of the use of ``` within powershell. I'm researching syntax and operators. Until then I was wondering if anyone can confirm successful use of the command in step II since the 7/6/2021 post update date, or as a secondary offer any insight on the encountered error. Any input is greatly appreciated.

i wonder if the three backticks ("```") are just remnant formatting since that's how we usually format tidal code snips (here in the forum for example). have you tried removing those characters and re-running it? i've never used chocolately (i've just done the manual install on windows and it was fairly easy using the cygwin terminal) so this is just a blind guess!

1 Like

I haven’t turned up their use in the context of, so your intuition may be a very educated blind guess. Thank you, I’ll try this tonight and report back.

That did the trick. I’m not getting sound from tidal, but I can dig into that tomorrow. Once again, I appreciate your insight.

1 Like

i'm so glad i could be of assistance! normally i'm totally useless hahaha. i can try to help diagnose the no sound thing, too. can you navigate to where your superdirt quark is saved on your local drive? it should be somewhere around here:

C:\Users*YOUR USER NAME*\AppData\Local\SuperCollider\downloaded-quarks\SuperDirt

check the date modified on all the files and folders...if they look pretty old, let's get you the latest superdirt quark from github.

go to: GitHub - musikinformatik/SuperDirt: Tidal Audio Engine

download a ZIP of the latest batch of files and folders and then copy/replace whatever is in your current superdirt folder. this solved the no-sound issue for me just this week. let me know.

Thanks kit-christopher. I think I just wasn't getting SuperDirt started last night. I got things running tonight, but I do appreciate your post. I'm running through the documentation now trying to soak it in bit by bit.

1 Like