Installation freeze MacOS Catalina

Hi, im having problems installing tidal on MacOS Catalina 10.15.7. I've tried running the installation script and manual installation, but it keeps getting stuck at "Building network- (all, legacy fallback)" while installing the tidal library. I have let it run for hours, is this a known issue?

I just had the same issue on OsX 10.15.17. I tried a bunch of things and in the end it came down to using "compatible" versions of ghc and cabal. The versions that worked for me were:

ghc: 8.10.1

The osx install script provided by tidal pulls in an install script for haskell. I pulled that manually and added these lines to the top of it

# download haskell install script and then edit it
> curl >
> cp haskell-install{,-hacked}.sh
> vi

then run

> sh
> cabal update
> cabal install tidal --lib

Along the way playing with things, I found that the same result could be had like this:

> curl -sSf | sh
> ghcup install ghc 8.10.1
> ghcup install cabal
> ghcup set ghc 8.10.1
> ghcup set cabal
> cabal install tidal --lib
1 Like

wow dgb thank you so much!! works perfectly. you are truly a lifesaver i was getting soo frustrated <33333 Thank you!

1 Like

One note for anybody using ghcup to try out different versions. I had at least one case where I:

  • installed test versions of ghc/cabal only for the tidal install to fail
  • installed the working versions (as I listed above) and still had failures building tidal because some dependent library was built with different/incompatible versions of some other libraries.

The only way I got past that was to blow away the ghc/cabal install and start over fresh.