Linux install script fails

hey there,

running the install script (sh from gives me the following error:

[ 27%] Built target boost_regex_lib
Makefile:162: recipe for target 'all' failed
make: *** [all] Error 2

i am on Linux Mint ver 19.3.

should i try something different?


Hi! Try editing, finding -DSC_EL=ON, and changing that to -DSC_EL=OFF. Then try running it again. You might have to run make clean too, wouldn’t hurt!

thanks! that seemed to work... the error message is gone and the script reaches 100% :slight_smile:

EDIT: following the installation tutorial after this, i had a hard time figuring out how to even launch supercollider so i could install superdirt :laughing:

after looking around on the supercollider website, i figured it out: the command is "scide" -- maybe add that to the linux instructions?

yes, launch scide then type
then select SuperDirt

thanks vrx!

i'm getting very close :grinning: SuperCollider is running now (i get SuperDirt: listening to Tidal on port 57120 when running SuperDirt.start in supercollider) -- but somehow TidalCycles in Atom is giving me trouble now. I get the following error when i select TidalCycles > Boot TidalCycles

No configured ghc path

Ghci command: ghci Ghc-pkg command: ghc-pkg

it seems something is wrong with the haskell compiler?

EDIT: but hey! there is actually sound! :smiley: :smiley:

Hm, does ghci work from the commandline?
Did you install haskell etc from the instructions?
edit: ah great!

yes it totally works now :star_struck:
i have no clue why it didn't at the first go. perhaps i had to just reboot for the changes to take effect. but not really sure what happened tbh.

so it seems this is still creating some problems for me and my computer…

first time i run supercollider, start superdirt and load up atom, things work just beautifully.

but when supercollider / superdirt is running, youtube/mixcloud stops playing?!? and it starts again once i stop supercollider (server -> kill all servers)?

once i am done with youtube, and i want to relaunch superdirt, i can’t get it to complete launch. this is the log of supercollider:

-> SuperDirt
Booting server 'localhost' on address
Found 0 LADSPA plugins
Faust: supercollider.cpp: sc_api_version = 3
Faust: FaustGreyholeRaw numControls=7
Faust: supercollider.cpp: sc_api_version = 3
Faust: FaustJPverbRaw numControls=11
JackDriver: client name is 'SuperCollider'
SC_AudioDriver: sample rate = 48000.000000, driver's block size = 128
JackDriver: connected  system:capture_1 to SuperCollider:in_1
JackDriver: connected  system:capture_2 to SuperCollider:in_2
JackDriver: connected  SuperCollider:out_1 to system:playback_1
JackDriver: connected  SuperCollider:out_2 to system:playback_2
SuperCollider 3 server ready.
JackDriver: max output latency 8.0 ms
Requested notification messages from server 'localhost'
localhost: server process's maxLogins (1) matches with my options.
localhost: keeping clientID (0) as confirmed by server process.
Shared memory server interface initialized
loading synthdefs in /home/jacob/.local/share/SuperCollider/downloaded-quarks/SuperDirt/classes/../synths/core-modules.scd
---- core synth defs loaded ----
loading synthdefs in /home/jacob/.local/share/SuperCollider/downloaded-quarks/SuperDirt/classes/../synths/core-synths-global.scd
loading synthdefs in /home/jacob/.local/share/SuperCollider/downloaded-quarks/SuperDirt/classes/../synths/core-synths.scd
loading synthdefs in /home/jacob/.local/share/SuperCollider/downloaded-quarks/SuperDirt/classes/../synths/default-synths.scd
exception in GraphDef_Recv: exceeded number of interconnect buffers.
loading synthdefs in /home/jacob/.local/share/SuperCollider/downloaded-quarks/SuperDirt/classes/../synths/try-load-extra-synths.scd
loading synthdefs in /home/jacob/.local/share/SuperCollider/downloaded-quarks/SuperDirt/classes/../synths/tutorial-synths.scd

loading 217 sample banks:
808 (6) 808bd (25) 808cy (25) 808hc (5) 808ht (5) 808lc (5) 808lt (5) 808mc (5) 808mt (5) 808oh (5) 808sd (25) 909 (1) ab (12) ade (10) ades2 (9) ades3 (7) ades4 (6) alex (2) alphabet (26) amencutup (32) armora (7) arp (2) arpy (11) auto (11) baa (7) baa2 (7) bass (4) bass0 (3) bass1 (30) bass2 (5) bass3 (11) bassdm (24) bassfoo (3) battles (2) bd (24) bend (4) bev (2) bin (2) birds (10) birds3 (19) bleep (13) blip (2) blue (2) bottle (13) breaks125 (2) breaks152 (1) breaks157 (1) breaks165 (1) breath (1) bubble (8) can (14) casio (3) cb (1) cc (6) chin (4) circus (3) clak (2) click (4) clubkick (5) co (4) coins (1) control (2) cosmicg (15) cp (2) cr (6) crow (4) d (4) db (13) diphone (38) diphone2 (12) dist (16) dork2 (4) dorkbot (2) dr (42) dr2 (6) dr55 (4) dr_few (8) drum (6) drumtraks (13) e (8) east (9) electro1 (13) em2 (6) erk (1) f (1) feel (7) feelfx (8) fest (1) fire (1) flick (17) fm (17) foo (27) future (17) gab (10) gabba (4) gabbaloud (4) gabbalouder (4) glasstap (3) glitch (8) glitch2 (8) gretsch (24) gtr (3) h (7) hand (17) hardcore (12) hardkick (6) haw (6) hc (6) hh (13) hh27 (13) hit (6) hmm (1) ho (6) hoover (6) house (8) ht (16) if (5) ifdrums (3) incoming (8) industrial (32) insect (3) invaders (18) jazz (8) jungbass (20) jungle (13) juno (12) jvbass (13) kicklinn (1) koy (2) kurt (7) latibro (8) led (1) less (4) lighter (33) linnhats (6) lt (16) made (7) made2 (1) mash (2) mash2 (4) metal (10) miniyeah (4) monsterb (6) moog (7) mouth (15) mp3 (4) msg (9) mt (16) mute (28) newnotes (15) noise (1) noise2 (8) notes (15) numbers (9) oc (4) odx (15) off (1) outdoor (6) pad (3) padlong (1) pebbles (1) perc (6) peri (15) pluck (17) popkick (10) print (11) proc (2) procshort (8) psr (30) rave (8) rave2 (4) ravemono (2) realclaps (4) reverbkick (1) rm (2) rs (1) sax (22) sd (2) seawolf (3) sequential (8) sf (18) sheffield (1) short (5) sid (12) sine (6) sitar (8) sn (52) space (18) speakspell (12) speech (7) speechless (10) speedupdown (9) stab (23) stomp (10) subroc3d (11) sugar (2) sundance (6) tabla (26) tabla2 (46) tablex (3) tacscan (22) tech (13) techno (7) tink (5) tok (4) toys (13) trump (11) ul (10) ulgab (5) uxay (3) v (6) voodoo (5) wind (10) wobble (1) world (3) xmas (1) yeah (31) 
... file reading complete. Required 444 MB of memory.

note that it doesn’t arrive at the “SuperDirt: listening to Tidal on port 57120” line…?

Yes by default jackd stops pulseaudio, which desktop apps use. There’s a lot of obscure information online about how to get them to work together, but I think these days it’s as simple as installing the pulseaudio-module-jack package. I find this doesn’t always work, though.

Unrelatedly the exception in GraphDef_Recv: exceeded number of interconnect buffers. looks concerning, in the video I posted recently you can see how to start superdirt with more options. I think you might need to add this extra line to the list of configuration options there: s.options.numWireBufs = 128;

1 Like

OK, great -- things are working smoothly now! even with youtube running in the background :slight_smile:

i had to follow these instructions to get jackd and pulseaudio to co-exist:

copying the contents of superdirt_startup.scd to startup.scd fixed tidal / superdirts issues with starting up. i now get SuperDirt: listening to Tidal on port 57120 every time i start supercollider :slight_smile: yay!

also, adding s.options.numWireBufs = 128; fixed the exception in GraphDef_Recv: exceeded number of interconnect buffers.



Hey.. more jack problems.Everything was working .Then I ran PureData, during which some strange Jack errors occurred, and now when I start SC, Jack does not come completely up and the patchbay which usually has the connections to SC is empty. Looks like the problem I was having before. When Jack comes up I get this -

22:22:08.995 Statistics reset.
22:22:09.000 ALSA connection change.
22:22:09.007 D-BUS: Service is available (org.jackaudio.service aka jackdbus).
22:22:09.062 JACK connection change.
22:22:09.080 Client activated.
22:22:09.081 Patchbay deactivated.

Is there a way to reload the patchbay configuration? I saw the instructions here :

but it wasn't clear how the pajackconnect script is installed. I'll keep poking away at it. At least I am caught up

tom k

Hi...I'm having similar jack problems that you had.

I actually had everything working, then I ran PureData and that did something that is causing jack and SC to have a conflict

I installed the pajackconnect package, added the "paconnectjack start" and paconnectjack stop and paconnectjack reset lines

Now getting these errors in the Qjacktl console (I was getting them before I installed pajackconnect also):
2:22:08.995 Statistics reset.
22:22:09.000 ALSA connection change.
22:22:09.007 D-BUS: Service is available (org.jackaudio.service aka jackdbus).
22:22:09.062 JACK connection change.
22:22:09.080 Client activated.
22:22:09.081 Patchbay deactivated.

In the messages for SC, this is the last line I get (no Tidal listening message)
... file reading complete. Required 225 MB of memory.

Did you do the "For use JACK without PulseAudio??, section of the instructions?

Appreciate any feedback you can provide.


tom k

Got this working 2 minutes after sending email :slight_smile:

Had to turn off pulse audio

Sorry for the trouble.

tom k


haha no worries :wink: