How are you doing with the install process?

I think this is what you want:

If you want to update docs, Instructions at

say startup.scd should go here : ~/Library/Application\ Support/SuperCollider/startup.scd

Which looks like a MacOS path. Looked this up and put it in ~/.config/SuperCollider/startup.scd

I presume that you have to restart SC if it is already running? Does jackd need to be restarted? I’m getting the realtime scheduling error, SC3 plugins not found and

WARNING: Dirt could not load some synths from default-synths.scd, because sc3plugins are necessary and missing.

I did install from the Linux script.

UPDATE : everything is working…just need to look up how to switch default audio device in jack.

Will start looking through other docs.

Tom K

1 Like

Hi, Weird Issue. I cannot play youtube videos in either Chrome browser or Firefox after installing supercollider. Youttube videos just pause, and don’t play.

I am not sure where to put this, because it’s not really about the install process, but it is a side effect I have noticed.

So! I am putting it here.
I am running Debian Buster on an Lenovo T430 laptop. This is a default install, with a Gnome desktop environment. (When I say default, I mean I have only installed software via apt). It is a laptop I use for music, so I will have installed qjackctl and some other Debian Gnu/Linux things. However, I’ve not done anything, except install packages via apt, this involves Google Chrome browser ( from Google repo) and Firefox LTR from Debian

I followed the install instructions. Everything worked first time. (Compiling SuperCollider, adding the SC plugins etc. )
I followed the instructions from here

This is what I did in detail

sudo dpkg -i atom-amd64.deb 
sudo apt-get install build-essential cabal-install git jackd2
mkdir src
cd src/
git clone
cd build-supercollider
cabal update
cabal install tidal

Anyway, If anyone knows how to fix it, please tell, me. It’s not super important. I can watch the videos separate from launching supercollider, but it would be nice, not to have to close supercollider first whilst watching them.

Thanks in advance.

I’ve installed Tidal on a laptop running Ubuntu Budgie 18.04. Works perfectly, except I am having the same problem as Kate… YouTube videos don’t play, but had not connected the dots until I read her post. In the meantime, I am watching the videos on a iPad Pro.


1 Like

I first tried installing on Windows 10 via chocolatey, but had problems. I uninstalled everything then went through the manual install method without any issues.

1 Like

@kate @tkarches for the problem with YouTube audio stopping on Linux when SuperCollider runs, have a look at this post:

1 Like

Hi @tkarches, which linux install script? I don’t think there is one linked from the install page. I have got a version of the mac tidal-bootstrap install that works under linux (I’m still to test that properly), but that installs atom, not emacs.

Thanks for the report. I hope to work on the chocolatey install soon, having problems getting a testing environment working.

Hi @tedthetrumpet thanks, I have a solution now. For me there were a couple of extra steps involved.

  • Issue: Browser does not play sound (Neither Firefox/Chrome) after following super
  • Steps to reproduce:
    Follow instructions here to install supercollider and tidal.
    After starting supercollider youtube videos do not play (and eventually show the following error Screenshot from 2020-04-14 11-28-10

OS: Debian Buster; default installation, with the default Gnome desktop environment. (I like Debian, and I like the defaults!)

  • Install "pulseaudio-module-jack"
    kate@sound:~$ sudo apt install pulseaudio-module-jack
  • Start supercollider as normal - This starts the jackd server
  • After supercollider has started load the "jack-source" and "jack-sink" modules
    kate@sound:~$ pactl load-module module-jack-sink
    kate@sound:~$ pactl load-module module-jack-source

After doing this go to the gnome sound applet. A new output device will have appeared.

Select this as the output.

Now youtube videos will play! :slight_smile:


Thanks @Kate!
Through this install process, I'm pleasantly surprised at how many Linux people have popped up. I've always developed and used Tidal under Linux but have not noticed many other users until now. Lets not get tribal about it though, respect also to the windows and mac crews :wink:

1 Like

Hi @yaxu, I am definitely not tribal. I also don't really like "faffing" with computers! I am definitely in the "It should just work" camp. Lifes too short to spend looking at a screen anymore than necessary! :wink:

Is there a way to get SuperCollider to do the pactl load-module blah thing automatically when it starts ?

1 Like

I think you could put e.g. "pactl load-module blah".unixCmd; to your supercollider startup file.

I didn't mean to say you were being tribal, just felt myself getting that way while writing, and keeping myself in check! :slight_smile:

1 Like

@kate great walkthrough. This question comes up a lot… maybe this answer could be shared more widely?


I have added

// get PulseAudio and Jack to work together  - KD 2020-04-14
"pactl load-module module-jack-sink".unixCmd;
"pactl load-module module-jack-source".unixCmd;

to my startup. It needed to go inside the s.waitForBoot { ... }; stanza.

Now everything just works! :slight_smile:


I just ran the steps from the Linux install page, not really a script.

tom k

I use both Linux and MacOS but use Linux for music stuff where possible due to generally lower overhead and fewer potential interaction problems with other stuff running on the system. Right now I am running both Tidal and my work-from-home apps on the same system, but there is something to be said for dedicating a system for just doing music regardless of which OS I am using. I have seen performances go wrong more than once when there was an unfortunate interaction with something else on the computer.

tom k.


I used the script here -

$ git clone
$ cd build-supercollider
$ sh
$ sh

Just to be sure, I ran the last step again. Did not complete successfully

So, I quit Atom, then tried to quit SC, and it just hung. Killed it, restarted. Got the port in use error, killed 2 of the SC processes. Appparently not enough. What all do I have to kill if SC hangs? I only saw 2 processes that began with sc.


Yes there should only be scsynth and sclang processes.
You can find out what's listening on a port with lsof -i :57120. You might need to apt install lsof


jackd was keeping the port open. stopping it was not enough. quitting was not enough. Had to kill it.

probably had something to do with the pulse audio/jack module

still getting this

WARNING: Dirt could not load some synths from default-synths.scd, because sc3plugins are necessary and missing.


SC3-Plugins not found. This is not a problem.Note that we are using a comb delay, which may not sound the same as SwitchDelay from the plugins

so tidal is working but Im getting a bunch of these on the SC console

no synth or sample named 'lo' could be found.
module 'sound': instrument not found: nil

The bolded stuff is console messages

New info : , if I try to quit SC and Jack is running, it hangs until I kill jackd

tom k

Hmmm. I added those lines and now whenever I restart SuperCollider it fails because port 57120 is being used by jackd. Had to kill it (quit or stop not good enough). Are you seeing that at all?

also, if SC is running and I try to quit, it hangs until I kill jackd

tom k