Looking for help with Mac support

Hi all,

I'm looking for a good way of supporting both silicon and non-silicon macs.

If you have a non-silicon Mac, does this command work to install ghcup?

curl --proto '=https' --tlsv1.2 -sSf https://get-ghcup.haskell.org | arch -x86_64 /bin/bash

If you have a silicon Mac, what happens when you try to run the tidal-bootstrap installer?

curl https://raw.githubusercontent.com/tidalcycles/tidal-bootstrap/master/tidal-bootstrap.command -sSf | sh

Thanks!

Screen Shot 2021-03-02 at 10.38.42 PM

curl --proto '=https' --tlsv1.2 -sSf https://get-ghcup.haskell.org | arch -x86_64 /bin/bash
...
Installation done!

Looks like it worked!

Log: https://pastebin.com/0fDwCNwY

Thanks very much! The more reports the better, if others have a Mac to hand.

System: MacBook Pro Big Sur (13', 2020, four thunderbolt 3). 2Ghz Intel Core I5 Quad Core, 16Go 3733 MHz LPDDR4X.

Runned the non-silicon command. It installed everything flawlessly. My logs are identic to what @ycck got.

1 Like

Hi all,

The saga:
TidalCycles had stopped working a while ago - everything had become such a tangled mess I could not be bothered to sort it out. Waiting for the new ARM iMacs so I could make a fresh start.

However seeing this on Friday I spent the evening fixing the numerous errors generated from the curl --proto script.

Restart and everything was working splendidly.

Alas returning to it today everything seems to be working but there is no sound. Atom says:

Listening for external controls on 127.0.0.1:6010
Connected to SuperDirt.

sending a:
d1 $ sound "asldfkjasdf"

SuperCollider returns:
no synth or sample named 'asldfkjasdf' could be found.
module 'sound': instrument not found: asldfkjasdf

I can .play a sound in SuperCollider.

Tried updating to SuperCollider 3.11 but it did not seem to launch properly so reverted to 3.10.

Any suggestions?

To answer your question:
does this command work to install ghcup?

Yes - eventually. It kept insisting that /.ghcup/bin/ghcup was not there when it clearly was but that was probably due to the aforementioned tangled mess :confused:

Intel i5 iMac. MacOS 11.2.2 (Big Sur). SuperCollider 3.10.3 TidalCycles 1.7.2. Atom 1.54.

Hi @Duncan, sorry you've had some troubles!

SuperCollider 3.10 on big sur loses time sync over time, so after a while it'll stop working (or work but with a very long delay) until you reboot. You will need the supercollider version with "BigSur" in it, from here: https://supercollider.github.io/download

When you say 3.11 doesn't seem to launch properly, check you have that BigSur version, and share any errors you see in the post window in full.

1 Like

Ah! Had missed the separate Big Sur version. All is working again now. Thanks.

1 Like

I have an Intel Mac and just received an M1 Mac this week for testing my company's dev builds. If I run the Tidal Bootstrap script on the M1 (using fish or bash) I receive the same error:

Hi @trickyflemming, can you try this instead please:

curl https://raw.githubusercontent.com/tidalcycles/tidal-bootstrap/master/tidal-bootstrap.command -sSf | arch -x86_64 /bin/bash

Excellent, thank you! That got it up and running.

I had to take one extra step and manually add ~/.ghcup/bin to my PATH. This computer has been a bit of a developer's nightmare to setup with all of the, uh, "security" features. I also removed Atom and the auto-installed version of SuperCollider, as 3.11.2 is compatible with Big Sur and Apple Silicon via Rosetta.

You can see a few issues in the opening below. Mainly, macOS now uses zsh as default, so it attempts to grep a non-existent .bashrc file.

Hi Yaxu,

Thanks for asking this! I'm having a lot of difficulty installing. Here's my computer's specs:

OSX 10.11.6
Core Duo 2 Macbook Pro

I've got as far as installing Supercollider, SuperDirt, Atom and Haskell. But I get this error in Atom when I try and load the Tidal package:

Choose ghcup default path: /Users/davidturner/.ghcup/bin

Ghci command: /Users/davidturner/.ghcup/bin/ghci Ghc-pkg command: /Users/davidturner/.ghcup/bin/ghc-pkg

Start atom-tidalcycles plugin

Load BootTidal.hs from /Users/davidturner/.atom/packages/tidalcycles/lib/BootTidal.hs

Cannot browse tidal to obtain informations for autocomplete: Error: Command failed: echo ":browse Sound.Tidal.Context" | "/Users/davidturner/.ghcup/bin/ghci" /bin/sh: /Users/davidturner/.ghcup/bin/ghci: No such file or directory

t> /bin/sh: /Users/davidturner/.ghcup/bin/ghci: No such file or directory

  • Git

  • GitHub

Create Repository

Initialize /Users/davidturner/Documents/Live Coding with a Git repository

Create repository

~/Documents/Live Coding/test.tidal

In the top right of the Atom window it has this:

Uncaught Error: write EPIPE
events.js:200
Hide Stack Trace
Error: write EPIPE
at afterWriteDispatched (internal/stream_base_commons.js:149:25)
at writeGeneric (internal/stream_base_commons.js:140:3)
at Socket._writeGeneric (net.js:776:11)
at Socket._write (net.js:788:8)
at doWrite (_stream_writable.js:435:12)
at writeOrBuffer (_stream_writable.js:419:5)
at Socket.Writable.write (_stream_writable.js:309:11)
at Ghci.writeLine (/Users/davidturner/.atom/packages/tidalcycles/lib/ghci.js:20:24)
at REPL.tidalSendLine (/Users/davidturner/.atom/packages/tidalcycles/lib/repl.js:118:15)
at REPL.initTidal (/Users/davidturner/.atom/packages/tidalcycles/lib/repl.js:96:12)
at REPL.start (/Users/davidturner/.atom/packages/tidalcycles/lib/repl.js:34:10)
at HTMLElement.tidalcyclesBoot (/Users/davidturner/.atom/packages/tidalcycles/lib/tidalcycles.js:41:23)
at CommandRegistry.handleCommandEvent (/Applications/Atom.app/Contents/Resources/app/static/:11:351740)
at CommandRegistry.dispatch (/Applications/Atom.app/Contents/Resources/app/static/:11:350215)
at AtomEnvironment.dispatchApplicationMenuCommand (/Applications/Atom.app/Contents/Resources/app/static/:1:786863)
at EventEmitter.t (/Applications/Atom.app/Contents/Resources/app/static/:1:794834)
at EventEmitter.emit (events.js:223:5)
at Object.onMessage (electron/js2c/renderer_init.js:115:818)

I get the impression it's something to do with my Haskell install, or 'cabal', although I have no idea what the latter is.

I tried installing via Slack but that didn't seem to work, either. I might not have done it correctly, though, as I really have no clue what I'm doing! :slight_smile:

Hi @david_t, cabal and stack are both ways to install Haskell libraries, such as tidal.

From these errors it seems like haskell isn't actually installed. How did you (try to) install it? Did you try rebooting afterwards? What does this command say: whereis ghci ?

Thanks @yaxu.

whereis ghci gets no response.

I tried the tidal-bootstrap installer first, but that came up with a lot of errors. I also tried installing via ghcup but got these errors:

[ Info ] verifying digest of: ghc-8.10.4-x86_64-apple-darwin.tar.xz
[ Info ] Unpacking: ghc-8.10.4-x86_64-apple-darwin.tar.xz to /var/folders/w8/dlkf7d4j65gct1xh52mtd3wr0000gn/T/ghcup-kLqdbw
dyld: lazy symbol binding failed: Symbol not found: _futimens
Referenced from: /Users/davidturner/.ghcup/bin/ghcup (which was built for Mac OS X 10.13)
Expected in: /usr/lib/libSystem.B.dylib

dyld: Symbol not found: _futimens
Referenced from: /Users/davidturner/.ghcup/bin/ghcup (which was built for Mac OS X 10.13)
Expected in: /usr/lib/libSystem.B.dylib

sh: line 45: 548 Trace/BPT trap: 5 ghcup "$@"
"_eghcup --cache install ghc recommended" failed!

I guessed from this that the Haskell install didn't work on my Mac OS. Found someone else referring to Haskell 8.6.3 for my Mac OS so hunted around for that version. Found this:
Haskel 8-6-3

I saw that the above webpage only loads the compiler, but wasn't too sure if that mattered so gave it a go! After I did that, the command ghci started producing:
GHCi, version 8.6.3: http://www.haskell.org/ghc/ :? for help

And yes, I rebooted after each attempt to install.

It sounds like I need a full install of Haskell (not just the compiler) for my OS. (I realise this is probably face-palmingly obvious, so apologies.) Is that right? If so, any idea where I'd find one?

Thanks!

That's a strange error, sorry can't help with that :confused:

You could get 8.6.3 with cabal etc as the 'haskell platform' from here:
Haskell Platform - Included Packages

Thanks for the link. Still haven't managed to get Tidal working on my Mac, but have resurrected an old PC laptop and installed it on that. Really enjoying working through the tutorials so far! :slight_smile: