MacOS Sierra install issue

I'm getting the following error trying to install on macOS Sierra Version 10.12.6 (16G2136)

Does anyone know how to fix this? Thanks!

$ cabal install tidal 
Resolving dependencies...
Build profile: -w ghc-8.8.3 -O1
In order, the following will be built (use -v for more details):
 - blaze-builder-0.4.1.0 (lib) (requires download & build)
 - base-orphans-0.8.2 (lib) (requires download & build)
 - cabal-doctest-1.0.8 (lib) (requires download & build)
 - clock-0.8 (lib) (requires download & build)
 - colour-2.3.5 (lib) (requires download & build)
 - data-binary-ieee754-0.4.4 (lib:data-binary-ieee754) (requires download & build)
 - hsc2hs-0.68.7 (exe:hsc2hs) (requires download & build)
 - primitive-0.7.0.1 (lib) (requires download & build)
 - random-1.1 (lib) (requires download & build)
 - tagged-0.8.6 (lib) (requires download & build)
 - th-abstraction-0.3.2.0 (lib) (requires download & build)
 - transformers-compat-0.6.5 (lib) (requires download & build)
 - network-3.1.1.1 (lib:network) (requires download & build)
 - vector-0.12.1.2 (lib) (requires download & build)
 - distributive-0.6.2 (lib:distributive) (requires download & build)
 - hosc-0.18 (lib) (requires download & build)
 - comonad-5.0.6 (lib:comonad) (requires download & build)
 - bifunctors-5.5.7 (lib) (requires download & build)
 - tidal-1.6.0 (lib) (requires download & build)
Downloading  base-orphans-0.8.2
Downloaded   base-orphans-0.8.2
Downloading  clock-0.8
dyld: lazy symbol binding failed: Symbol not found: _utimensat
  Referenced from: /Users/nput/.ghcup/bin/cabal (which was built for Mac OS X 10.13)
  Expected in: /usr/lib/libSystem.B.dylib
dyld: Symbol not found: _utimensat
  Referenced from: /Users/nput/.ghcup/bin/cabal (which was built for Mac OS X 10.13)
  Expected in: /usr/lib/libSystem.B.dylib
Abort trap: 6

wrong OS version? cf. https://github.com/rbenv/ruby-build/issues/1133#issuecomment-330985090

next step would be to run cabal install -v to see the actual command that failed