macOS Ventura installation issues "-no_fixup_chains"


I'm trying to install Tidal 1.9.4 using either cabal or stack but installation keeps failing to build clock, network and tidal-link due to "error: ld: unknown option: -no_fixup_chains".

I'm on an intel mac, updated to Ventura 13.6, running ghc 9.4.7 cabal

Has anyone else faced this issue or know of a workaround?


Fixed the issue with this configuration in case anyone else runs into the same problem:

HLS: 2.4.0
Cabal: 3.10.1
GHC: 9.6.1

Thanks, I have the same issues, but couldnt install GHC 9.6.1 in the terminal.. any ideas??

If you install ghcup you can run the command ghcup tui which will show you a useful UI you can use to install other versions of GHC, Cabal and HLS etc. Select the version you'd like and type i to install followed by s to set it as the default version on your system. Then re-run cabal install --lib tidal. For me tidal still doesn't show up as installed when I run cabal list tidal but it works as expected in Pulsar. Hope this helps!

I could do that and use the same versions as you but still my Pulsar gives error:

: error:
Could not find module ‘Sound.Tidal.Context’
It is not a module in the current program, or in any known package.

I have the latest SuperDirt installed in SC... Any ideas??

Looks like Tidal still hasn't successfully built for you, what does your terminal say when you install tidal?

If you see the message:

Error: cabal: Packages requested to install already exist in environment file
at /Users/<your_home_directory>/.ghc/x86_64-darwin-9.6.1/environments/default. Overwriting
them may break other packages. Use --force-reinstalls to proceed anyway.
Packages: tidal

Run the command: cabal install --lib tidal --force-reinstalls.

I get these errors: ld: symbol(s) not found for architecture arm64

clang: error: linker command failed with exit code 1 (use -v to see invocation)

ghc-9.6.1: gcc' failed in phase Linker'. (Exit code: 1)

Error: cabal: Failed to build exe:hsc2hs from hsc2hs-0.68.10 (which is

required by tidal-1.9.4).

Hrmm seems like a similar issue to the one described here: Failed to build exe:hsc2hs from hsc2hs-0.68.7

Perhaps try opening a new terminal window or upgrading to GHC 9.6.2 or 9.6.3?

Are you on an Intel or M1?

M1, I'll try other versions and let you know, thank you so so much for the support, means a lot!

Good luck! I was able to get it running on M1 with a few extra steps, if you see complaints about ffi.h try installing with this command instead:

C_INCLUDE_PATH="`xcrun --show-sdk-path`/usr/include/ffi" cabal install tidal --lib --force-reinstalls base

(A mixture of suggestions from the previous link and this one: Could not load module ‘System.IO’ - #2 by jwaldmann)