Major Haskell conundrum

Ok, so i was messing around trying to get a custom OSC stream to sync with superdirt and I noticed there was an updated boot.hs file on the userbase with something new associated with cFrameTimespan. Figured it might make a difference so I popped it in and something went wrong. This is what I got:

t> Loaded package environment from /Users/student/.ghc/x86_64-darwin-8.8.4/environments/default
t> /Users/student/Desktop/TidalCycles/CustomBoot.hs:10:111: error:
    Not in scope: ‘cVerbose’
10 | tidal <- startTidal (superdirtTarget {oLatency = 0.1, oAddress = "", oPort = 57120}) (defaultConfig {cVerbose = True, cFrameTimespan = 1/20})
   |                                                                                                               ^^^^^^^^

Oh well I'll just pop my old boot.hs back in but then I got this:

t> : error:
    Could not load module ‘Sound.OSC.FD’
    It is a member of the hidden package ‘hosc-0.18.1’.
    You can run ‘:set -package hosc’ to expose it.
    (Note: this unloads all the modules in the current scope.)

I updated the tidal package but still nothing.
After some browsing on here I found someone getting the same error and @yaxu said to delete the package environment file reported here:

rm /Users/myname/.ghc/x86_64-darwin-8.10.4/environments/default

And reinstalling with this:

cabal update
cabal v1-install tidal

Removed the file but when I tried to run the reinstall I got this:

-bash: cabal: command not found

Now I realize something is up. Ran ghci in terminal and:
-bash: ghci: command not found

What is going on? What happened with Haskell? I could try reinstalling Haskell but seems weird that it just crashed entirely by just updating BootTidal.hs?

Does ghci-8.10.4 work? I've noticed the latest ghcup installers are a bit weird about making symlinks for different versions of ghc.