Midi Out doesn't work any more

Hello all,

I used to work with this SC commands to send Midi out commands from Tidal external hardware synthesizers for a long time. It allways worked fine.


~midiOut = MIDIOut.newByName("Revelator IO 24", "Revelator IO 24");

~dirt.soundLibrary.addMIDI(\sixtrak, ~midiOut);

~midiOut.latency = 0.225;

Now I get error messages from SC when I execute the second command, while SC had recogized my audio interface before durng the boot process. Could the error be related to the fact that I have updated to Tidal 1.9.3 in the meantime? What can I do now to send Midi Out commands from Tidal to external hardware again?

~midiOut = MIDIOut.newByName("Revelator IO 24", "Revelator IO 24");

I use macOS on a MacbookPro.

Any kind of help is welcome.


~midiOut = MIDIOut.newByName("Revelator IO 24", "Anschluss 1");

1 Like

Thank you very much @crcdng This small adjustment seems to work.

Glad it worked. In case someone else has the same problem:

MIDIClient.destinations; returns a list of current MIDI Outs, or MIDIEndPoints as pairs of device name and port name (which can be the empty string).

MIDIOut.newByName gets a device name and port name as parameters.

1 Like