Newbie here: need help with error booting Tidal

running on Win 11
installed everything through the auto-installer but I keep getting this message when trying to boot Tidal in Atom

C:\Users\zi.atom\packages\tidalcycles\lib\BootTidal.hs:42:41: error:
Not in scope: Sound.Tidal.Transition.mortalOverlay' NB: no module named Sound.Tidal.Transition' is imported.
42 | forId i t = transition tidal False (Sound.Tidal.Transition.mortalOverlay t) i
| ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

Does anyone know how I can fix it?

Hi, the choco installer is currently installing a new version of ghc that has problems. You could try fixing it with these four commands:

choco uninstall tidalcycles
choco uninstall ghc
choco install ghc --version 8.10.7 
cabal v1-install tidal

Please let us know how you get on.

Hey, thanks for replying!
I followed through but now I'm getting a different error message:

: error:
Could not find module `Sound.Tidal.Context'
It is not a module in the current program, or in any known package.

Also tried the steps in troubleshooting instructions and still not working?

Any help appreciated!

Hmm, could you try rebooting and then trying this part once more:

cabal v1-install tidal

I'm getting this from the terminal:

Resolving dependencies...
Up to date

@ WARNING: Installation might not be completed as desired!
The command "cabal install [TARGETS]" doesn't expose libraries.
* You might have wanted to add them as dependencies to your package. In this
case add "tidal" to the build-depends field(s) of your package's .cabal file.
* You might have wanted to add them to a GHC environment. In this case use
"cabal install --lib tidal". The "--lib" flag is provisional: see for more information.

Any idea what this could mean?

That probably means you did cabal install tidal instead of cabal v1-install tidal.

Without the v1- it needs an extra --lib, to make the full command cabal install tidal --lib. But the v1-install version is more reliable..

1 Like

Try this, it worked for me and some other people:
Uninstall ghc and tidal, completely delete the c:\tools and c:\Users\<user>\AppData\Roaming\cabal folders and reinstall by hand:

choco install ghc --version 8.10.7
choco install mingw
choco install msys2

Add c:\tools\msys64\usr\bin to the system path and reboot.

cabal install tidal-1.8.1 --lib

When I install tidal it says this following the step above:

PS C:\Users\admin> cabal install tidal-1.8.1 --lib
Resolving dependencies...
Build profile: -w ghc-8.10.7 -O1
In order, the following will be built (use -v for more details):
 - network- (lib:network) (requires build)
 - hosc-0.19.1 (lib) (requires build)
 - tidal-1.8.1 (lib) (requires build)
Starting     network- (all, legacy fallback)

Failed to build network- The failure occurred during the configure
Build log (
Configuring network-
Error: cabal.exe: The package has a './configure' script. If you are on
Windows, This requires a Unix compatibility toolchain such as MinGW+MSYS or
Cygwin. If you are not on Windows, ensure that an 'sh' command is discoverable
in your path.

Error: cabal.exe: Failed to build network- (which is required by
tidal-1.8.1). See the build log above for details.
1 Like

This happens if cabal can't find the executables in c:\tools\msys64\usr\bin. Make sure the former installations went without problems, and that you have correctly added this path to the system path.

1 Like

Thanks everybody for being so helpful!
I tried uninstalling ghc and tidal and reinstalling and it's working fine!


Could you explain how to uninstall ghc and tidal? Do I do it through Powershell? With Choco or Cabal? I tried typing "choco uninstall ghc" into Powershell and got the error message:

ghc not uninstalled. An error occurred during uninstall:
 Unable to uninstall 'ghc 8.10.7' because 'haskell-dev 0.0.1' depends on it.

Nevermind! @joanq, after going through those instructions and using --force to force reinstalls of ghc and msys2, it worked! Thanks for your help! I hope that someday the install process for Tidalcycles is more accessible!


I'm glad you solved it! Have fun with Tidalcycles!