No Audio on Tidal

Hi everyone. I've just installed everything i need to use to make tidal work but I doesn't make any sound and it shows this:
sing default GHC system path definition

Ghci command: ghci Ghc-pkg command: ghc-pkg

Load BootTidal.hs from C:\Users\Teodora\AppData\Roaming\cabal\x86_64-windows-ghc-8.4.3\tidal-1.7\BootTidal.hs

t>

t>

t> Listening for controls on 127.0.0.1:6010

t>.
I've used the SuperCollider scope to see if the audio worked but nothing is moving.
So maybe the problem is between how Tidal and SuperCollider are connected, Can anyone help resolve this problem?

Hi @Hiddenviolence.

In SuperCollider in Language -> Quarks, what version of SuperDirt is installed? It should ideally be 'v1.7.2'. In atom/tidal, when you run tidal_version, what does it say? Again ideally this should be 1.7.

And just to check, did you run SuperDirt.start? If so, please share the full output via a https://pastebin.com/ link.

What tidal code are you running and what happens when you do so?

1 Like

I've installed the latest version of SuperDirt and now everything works well.
Thank you so much for the help!

Great I noticed that the manual install instructions on the website had an out-of-date version, which might have been the problem? Fixed now..

Same here...I've installed everything properly (removed *~/.ghc and ~/.cabal folders first). The updates were successful. SuperDirt and Tidal boots normally, and when I run, for instance, d1 $ s "bd" there seems to be no sound. The interesting thing is there are no error messages on both Tidal and Supercollider. Now I'm back to 1.4.5, the version that I was using before the update and everything's just fine. I'm on MacOS 10.13.6.

Hmm if there's no sound then I think it's just that superdirt isn't on the right version - it should be 1.7.2. Quarks like SuperDirt fail to update if you've modified files but you can do it from the commandline - see the other thread: Tidal 1.7 install problems

Problem solved! I manually deleted SuperDirt and Dirt-Samples folders from Quarks:) Reinstalled SuperDirt and now I have sound. Thanks Alex.

1 Like