No errors, but no sound

Hi everyone

I'm trying to get Tidal working for the first time for the the last days but cannot get it to work.

There are no errors, but I don't get any sound. Another project that uses SC is working (Overtone).

I used the easy install method and tried everything in the troubleshooting article and everything appears to be fine, but no sound.

I tried both starting Superdirt with the command line and in SC

This is the output in VS Code

Please I would love some pointers to see how I can solve this

(I also tried using Stack instead of Cabal but same result)

platform is Mac, updated everything to the latest version

Output from Superdirt/Supercollider (sclang)

and this is the output from Superdirt when I tried it in the SC app

The only message that looks like an error in the output when running

/Applications/SuperCollider.app/Contents/MacOS/sclang superdirt_startup.scd

is this

loading synthdefs in /Users/porsche/Library/Application Support/SuperCollider/downloaded-quarks/SuperDirt/classes/../synths/default-synths.scd exception in GraphDef_Recv: exceeded number of interconnect buffers.

but all the other lines that start with loading synthdefs show no error message

I see the same thing in other outputs so it all seems fine. it's like it's sending to a wrong port in VS Code but I don't see any errors, I hope someone recognizes this issue :frowning:

I tried this in SC and I hear a high pitch

(
SuperDirt.default = ~dirt;
(type: \dirt, s: \superchip, out: 0, n: 60).play
)

Hi @porche, you need the d1 $ bit at the start.. It looks to me like you're missing that off

1 Like

Hi @yaxu thanks for your message, I don't know if I understand it, do you mean here?

https://club.tidalcycles.org/uploads/thirdsite/original/2X/1/15ee4ec790b2f2dd846c7d222b044ca166a0df61.png

this is the output when I hit "shift enter" in VS Code after the line "sound "bd sn"", so how would I do that differently?

oh I see it's working now thanks @yaxu I should have come here earlier!! thank you!

1 Like

No problem!