No sound - No buffer data

Hi everyone,
I wanted to start making music with tidal, so installed everything following the instructions from the userbase. Everything seems to be working, but I get no sound when sending commands to SuperCollider from Atom. SC get the command (tried with a non existing sound and I get an error message), but no sound is played. Instead, I just get the error: Buffer UGen: no buffer data over and over again in the post window.
I changed s.options.numBuffers in the SC startup file from 1024 * 16 to 1024 * 32, hoping that messing a bit with this would help but it doesn't.
I got through the Troubleshooting steps but nothing in it seems to match with my problem.
This has probably already been solved elsewhere but I can't find anyhing relevant.
Thanks for your help

Hi @reptile_sadboi,
Yes seems that you have gone quite deep with the troubleshooting already.
Could you share the post window output that you get when you start superdirt? Maybe there is a clue there.

Okay so upon investigation, when SuperDirt is starting (I put the SuperDirt.start in the startup file so it launches basically right after I open SC.) I get a loooong scrolling display of
File 'C:\Users\Rémy\AppData\Local\SuperCollider\downloaded-quarks\SuperDirt\classes\..\..\Dirt-Samples\stomp\003_2.wav' could not be opened
with what seems to be pretty much every file in the downloaded-quarks folder, saying that it couldn't find the specified directory.
I checked and the folder exists, is in the right place and seems to contain all of the .wav files

Hm, could it be a permissions problem?

Ah it seems to be a problem with the accent in your name.

This seems to have been fixed, so upgrading supercollider should hopefully solve it.

Right, never thought having a French name would mess so much with computers, so I upgraded to SC 3.11.2 and everything works fine !
Well.. at least the first d1 $ sound "bd sn" is working, now starts the hardest part: learning how to use all of this, I guess I have a lot of reading and video-watching to do.
Thanks a lot !

1 Like

Great have fun!

I was also having trouble drawing sound out of this silent rock of a Macbook for the past week, and upgrading SuperCollider also fixed my issue ! I've tried just about everthing else -- time to get back to building :raised_hands: