No sound produced

Hi. I installed every package succesfully and I try to follow every step. First, I open SuperCollider and write SuperDirt.start. Then I open Atom, boot TidalCycles and write a simple line in a .tidal file (d1 $ sound "bd"). But it doesn't sound. The TidalCycles window only says the following:

Using default GHC system path definition

Ghci command: ghci
Ghc-pkg command: ghc-pkg

Listening for external osc messages on 127.0.0.1:3333

Like, it doesn't say anything about any error. What should I do?

Hmm that sounds a bit strange indeed. The message "Listening for external osc messages" is new and should perhaps be more meaningful, because this just means that you can trigger your code with OSC messages (see https://github.com/tidalcycles/atom-tidalcycles/releases/tag/v3.13.0).

But what I miss on the TidalCycles console output is the line "Load BootTidal from ...". What does your TidalCycles settings say to Boot Tidal Path (perhaps Default)? You can check this under Atom -> Preferences -> Packages -> tidalcyclces -> Settings

To check if you run into troubles on the SuperCollider side, you can check your output levels under Server -> Show Server Meter. If you see an output, than maybe you have to change your output device with s.options.outDevice. So maybe you need to modify your SuperCollider startup_script (you can find an example under https://github.com/musikinformatik/SuperDirt/blob/develop/superdirt_startup.scd) under File -> Open startup file

I changed the startup file from SuperCollider pasting the code from the link you sent me, just in case, and after booting TidalCycles the message is now:

Using default GHC system path definition

Ghci command: ghci
Ghc-pkg command: ghc-pkg

Load BootTidal.hs from C:\Users\Willy\AppData\Roaming\cabal\x86_64-windows-ghc-8.10.2\tidal-1.6.1\BootTidal.hs

Listening for external osc messages on 127.0.0.1:3333

t>

t>

t> Listening for controls on 127.0.0.1:6010

t>

And it just stays like that. No output showed up on SuperCollider's server meter after trying to run the line on Atom.

Sorry, it's my first time and it's very confusing.

Hmmm could you pls try the following? Open a console and type ghci.
This should open the GHC interpreter with a line like

GHCi, version 8.8.3: https://www.haskell.org/ghc/  :? for help
Prelude> 

Now you can type import Sound.Tidal.Context. The Prelude line should look like this now:

Prelude Sound.Tidal.Context>

This is a test to ensure that TidalCycles is installed correctly.

Yeah, apparently it's installed correctly. It went as you said.

That looks good in any case. I still think that SuperCollider uses the wrong soundcard. When the server is started in SuperCollider, information about the soundcard is listed. There it is listed which soundcards exist (with number and name) and which are used.

You can specify the sound card in the startup script, for example

(
s.reboot { 
   ...
   // Maybe something like this under windows
   // For the default audio driver 
   s.options.inDevice_("Realtek High Definition (HD");

   s.waitForBoot {
      ... 
   }
)

Maybe this helps?

I tried it but when I boot tidalcycles the message is:

Using default GHC system path definition

Ghci command: ghci Ghc-pkg command: ghc-pkg

Load BootTidal.hs from C:\Users\Willy\AppData\Roaming\cabal\x86_64-windows-ghc-8.10.2\tidal-1.6.1\BootTidal.hs

Listening for external osc messages on 127.0.0.1:3333

t>

t>

t> Listening for controls on 127.0.0.1:6010 Control listen failed. Perhaps there's already another tidal instance listening on that port?

t>

I algo have a problem on SuperCollider: the help guide says the low Server bar should show the numbers in green when the server is active, but I follow the steps to activate it and it still appears white.

can you paste here what returns on supercollider post window?

1 Like

Sorry, which one is that?

@igormpc means the Post window to the right in SuperCollider; see:

As you can see in my case the last line says SuperDirt: listening to Tidal on port 57120 and the text of the line below has green color.

And indeed could you please share the output of this window? This might get us closer to a solution.

1 Like

Sorry, I was out of home. It seems like the problem is here.

Hi.

I seem to have a similar problem and I can't figure out how to resolve it.

In Tidal, I get this message:
Choose ghcup default path: /Users/hasanhujairi/.ghcup/bin

Ghci command: /Users/hasanhujairi/.ghcup/bin/ghci Ghc-pkg command: /Users/hasanhujairi/.ghcup/bin/ghc-pkg

Load BootTidal.hs from /Users/hasanhujairi/.atom/packages/tidalcycles/lib/BootTidal.hs

t> Loaded package environment from /Users/hasanhujairi/.ghc/x86_64-darwin-8.8.3/environments/default

t>

t> Listening for controls on 127.0.0.1:6010

t> [TidalCycles v1.7]

While in SuperCollider, I get this notification:
*** Welcome to SuperCollider 3.10.3. *** For help press Cmd-D.
'/quit' message sent to server 'localhost'.
SCDoc: Indexing help-files...
'/quit' message sent to server 'localhost'.
Booting server 'localhost' on address 127.0.0.1:57110.
SCDoc: Indexed 1937 documents in 1.54 seconds

I suppose this means that that SuperCollider is sending out information to a different address compared to what Tidal through ATOM listens to a different address. Is there a way to fix this discrepancy in addresses?

Thank you!

These different ports are normal, 6010 is what tidal listens to for external control messages and is unrelated to superdirt.

If you don't have sound after upgrading tidal it's probably because superdirt is on an old version - the protocol changed slightly. Currently the latest superdirt is v1.7.2

2 Likes

Thanks very much for this. Yes, I ended up updating SuperDirt by downloading the latest folder from Github instead of trying to do it via Quarks in SuperCollider. I replaced the existing SuperDirt folder in my Quarks subfolder and this solved the issue.

Thanks again!

Ah good! There is something wrong with the quarks system I think. :confused:

1 Like