Only a cabal between me and a fuctioning tidal (some windows expert out there?)

Hi! I changed computer to a window 11 system and had to redownload everything to use tidal. I accidentally downloaded the latest versions og ghci and cabal so I threw them out and installed the proper ghci 9.4.1 version and...that's it, cause turns out I didn't actually managed to disnstall cabal 3.10.1 to install the 3.8.1, which is the one would solve all the problems I think. Indeed when booting on pulsar I get the "could not fine 'Sound.Tidal.Context'", and feels like a cabal related error in my case. The thing is when I use the "> choco install cabal --version= -force" appears the followinf error: "ERROR: The running command stopped because the preference variable "ErrorActionPreference" or common parameter is set to Stop: Microsoft.PowerShell.Commands.WriteErrorException
The install of cabal was NOT successful."
Even if I set the variable $ErrorActionPreference = Continue, it will still tell me that it is set on stop.........cringe
Can someone tell me if this is a solveble problem and if it's just related to the system or is something that I did? big thankssssss for anyone reading up until here kiss

I'm not a Windows expert and only have access to Windows via a VM. But here is my input:

  • the "Sound.Tidal.Context" error probably means that Tidal is not installed or it did not load properly.
  • follow the instructions here in the Manual Install > Haskell section: Windows | Tidal Cycles
  • use ghcup to sort this out, not choco
  • you need ghc 9.4.4 on Windows
  • fix ghc / cabal then install tidal packages again
  • validate your versions

Via powershell w admin

ghcup install ghc 9.4.4
ghcup install cabal
ghcup set ghc 9.4.4
ghcup set cabal

cabal update
cabal v1-install tidal 

Hope that helps.

1 Like

Ok big thanks for real,I tried since the beginning using ghcup and maybe this is what I have problem with...if I use the command ghcup on the admin powershell it sends the error
"ghcup : Termine 'ghcup' non riconosciuto come nome di cmdlet, funzione, programma eseguibile o file script." which transleted is the error of when a program is not in a reachable $PATH for the computer , but even trying to add the directory "C:\ghcup\bin" to the list the error still shows up... any idea on this one?
Also in the tidal manual says that the 9.4.1 ghc version is fine too for windows so that"s why I tried with that oneee, maybe should be updated

My suggestion is to get a complete fresh install of Haskell components. Delete ghcup, ghc, cabal, including:


To install ghcup follow the instructions on the haskell site - there is long powershell command there.

Then try the above ghcup commands to get the correct ghc, cabal and tidal versions.

I could not find where ghc version 9.4.1 is listed. Can you provide more detail?