OSX Script install fails (seems ghc-related)

I am running into the following problem when installing Tidal Cycles using the script install - I'm on OSX Catalina 10.15.7. It looks like what fails to install is Haskell via GHCup. If I try to install Haskell directly via this command I get the same error, see below:

[ Error ] Process "sh" with arguments ["./configure",
[ ...   ]                              "--prefix=/Users/ttt/.ghcup/ghc/8.10.7"] failed with exit code 77.
[ Error ] Also check the logs in /Users/ttt/.ghcup/logs
"_eghcup --cache install ghc recommended" failed!

As a result, when I try to boot the TidalCycles package in Atom, I get the following error:

Cannot browse tidal to obtain informations for autocomplete: Error: Command failed: echo ":browse Sound.Tidal.Context" | "/Users/ttt/.ghcup/bin/ghci"
/bin/sh: /Users/ttt/.ghcup/bin/ghci: No such file or directory

Does anyone know what could have gone wrong?
Thanks in advance for your help :slight_smile:


perhaps Help ""_eghcup --cache install ghc recommended" failed!" : haskellquestions ? (install xcode first)


It worked! Thank you so much :clap: