Problem with stack install

OK looks like I'm having trouble with the update :persevere:

When I installed tidal I used stack... Does anybody know how to remove it or in other words where did stack put tidal in the first place? I'm on Ubuntu.

I think I messed things up and would like to remove/uninstall and try again.


I'm not super familiar with stack but understand it can work well.. Did you try stack update; stack install tidal ? Or maybe stack install tidal-1.4.9

Otherwise I have a feeling that stack and cabal can co-exist fine. Probably you have something like stack ghci set up in your atom config and can just remove that to go back to the default.

Yeah I tried stack update; stack install tidal but looks like it didn't do much.
I now tried stack install tidal-1.4.9 and it did start compiling this time, and ends with a message like Registering library for tidal-1.4.9.. (so looks OK)

The problem is that once I start playing in the editor, tidal_version still says 1.4.8.
Sounds like there are both versions around and it keeps picking 1.4.8.

Yep good point. I'll give it one more go and if it fail I'll try this hopefully will work.

How about if you do this from the commandline:

stack ghci
import Sound.Tidal.Context

If that says 1.4.9, maybe your editor isn't actually using the stack version

hmm... it still says 1.4.8 :thinking:
Not sure what I've done to mess it up tbh.

Well I've now disabled the "use stack ghci" option from the editor and reinstalled tidal via cabal, works perfectly and it's 1.4.9. Will stick to this now. Thanks for your help @yaxu!

1 Like

Trouble with the update here, too. I wasn't able to get cabal and supercollider to work together when I first started, so I went with the stack installation.

I'm at the same place Dan was at before he disabled "use stack ghci" and reinstalled via cabal -- my editor is using 1.4.8 even through I was able to install with stack install tidal-1.4.9.

Is there any way to update the version used by Atom with stack?


Hi Miya! The latest tidal version is now 1.6.1 -- does stack install tidal-1.6.1 do something?

Hey! I tried that and the steps given for the commandline still result in "1.4.8".

I was able to install tidal-1.6.1 with cabal before and switched to stack because cabal wasn't allowing sound with supercollider.

I ended up downloading tidal twice without thinking, and that made things confusing with two versions of tidal-1.6.1 referenced by cabal.

There was a toplap chat topic that went into duplicate installations and how to remove a file for it, but I couldn't figure it out. Is there anything I could do in stack?

Thank you.

Hi Miya,

Hm so you have things set up in atom to use stack rather than cabal? Really this should work so I'm scratching my head here. Also there shouldn't be a big difference between a stack install and a cabal install, so one option would be to switch back to using cabal (changing the settings for the tidalcycles package in atom so the ghci path is the default), and try to work out what was going on there.

Fixed it! :+1:

1 Like