Pulsar being slow

I'm having some issues with Pulsar being slow when typing, it takes a second or so to catch up and is quite frustrating
Wondering if anyone was having a similar issue or if there are any possible solutions?

This only happens when the tidal package is running, without tidal everything is smooth and fast in Pulsar. Are there any other packages that I could try disable to help speed things up?

@Liimxa Yes, I had a similar issue with Pulsar - it focused on auto-complete functionality. I lived with it for some time before figuring out what to do.

  1. See the Pulsar page in the user docs: Pulsar | Tidal Cycles Several suggestions are given.

  2. Review the Settings of the Tidalcycles package in Pulsar. In the README section there is information on autocomplete, and using Hoogle.

Personally, I changed the settings in the autocomplete-plus package and I'm good now.

Aaah yes changing the delay before suggestions are shown sorted it, thank you!!!