Raspberry Pi 4 Install

So maybe a month or two ago, I was able to install Tidalcycles on Raspbian Buster just following the directions on Tidalcycles.org.

I tried doing a fresh install today, and I'm running into issues with the supercollider install. It says it's unable to locate qtwebengine5-dev (I'm not sure if that's exactly the issue) or if it's something with the cmake(?).

I was able to install it using sudo get install supercollider sc3-plugins but it wouldn't produce any sound when I ran some code.

Anyone with any luck or ideas? Thanks in advance!


Check out this post from @mattviveier

Thanks for the tip, @cleary! Through looking into Patchbox OS, I figured out what was wrong with my install.

I'm running a vga adapter to my monitor and using the 3.5mm jack for audio. For Youtube, the audio works, but when I use Tidalcycles, the audio reverts to hdmi. Any ideas? Thanks!

Are you running SuperCollider through the jackd audio subsystem?
If so you need to adjust the output device in jack (qjackctl can help there)


Thanks, @cleary!