SC not loading custom samples via startup.scd

Hello everyone,

I'm enjoying my experiences with tidal and with the learning course here so far, even if I am a bit late to the party.

I'm running Arch Linux and I've managed to install SuperCollider, SuperDirt and the TidalCycles package in Atom. I can make noises, so that's nice. I haven't been able to configure and install SC3-plugins, though, I'm hoping that doesn't cause too much of an issue.

One thing is I can't get SuperCollider to load 'samples-extra' (from the first week of the learning course) automatically. I included the following in my startup.scd, beneath the line '~dirt.loadSoundFiles;':


When I run it manually in SC works just fine, but not via startup.scd. I tried doubling 's.options.numBuffers' to 2048 * 512 without really knowing what I'm doing, that didn't work, neither did uncommenting 's.sync;'. I wonder if I am missing something simple?

edit: this is the startup.scd I'm using and the terminal output from sclang

Just an update to say everything is working now.

I got very muddled and thought the SuperCollider startup file should be in the directory


Whereas it was expected in