Supercollider not receiving any OSC data from Atom

Hi, after a recent reset of my system I obviously re-installed tidalcycles with all it's complementary software/dependencies. Doing all of that and booting up SC with the superdirt quark installed, it getting to listen to the right port and loading in my sample library, but running a line of code in atom does not seem to interact with supercollider at all. No synths get added to the server and I obviously don't get any sound. I see no errors at all in atom.

Here's the console output when running a line of code

Using default GHC system path definition
Ghci command: ghci
Ghc-pkg command: ghc-pkg
Load BootTidal.hs from C:\Users\lawre\AppData\Roaming\cabal\x86_64-windows-ghc-8.4.3\tidal-1.7.4\BootTidal.hs
t> [TidalCycles version 1.7.4]
Installed in C:\Users\lawre\AppData\Roaming\cabal\x86_64-windows-ghc-8.4.3\tidal-1.7.4
Listening for external controls on
t> [TidalCycles v1.7.4]

Hi @hogobogobogo,

That looks fine. No error messages in tidal 1.7.4 indicates that it's communicating well with superdirt. If you open up a scope in supercollider (click on numbers in bottom right to get a menu, then click on "show scope"), can you 'see' sound?

Hi @yaxu,

Receiving no audio on either of the channels. As I mentioned I don't see any synths getting added to the server. Tried re-installing the quark straight from Quarks.gui and tried again trough git (it does the same thing, but yeah). Other supercollider stuff is running just fine.

Following up on this. I ran OSCFunc.trace(true,true) and I'm indeed receiving Tidal OSC messages.

Ok. So does superdirt say SuperDirt: listening to Tidal on port 57120 when starting up?

When you play a non-existance sound like once $ sound "asldfjadslfkj", does an error come up in superdirt?

Can you share the output of running this in supercollider:


Yes, it's say's it.

EDIT: There is no error when playing that line of code

SuperDirt: listening to Tidal on port 57120
-> a SuperDirt
-> [ Quark: Vowel[472222fc51028abf749f56d89d21bd2fce434d17], Quark: Dirt-Samples, Quark: XML[0.21], Quark: wslib[0.31], Quark: crucial-library[4.1.6], Quark: ddwGUIEnhancements[1.0], Quark: ddwCommon[1.0], Quark: ddwEQ[1.0], Quark: Ctk[45fd2e60afa58a6ea651a16f0425a9b70ead23fe], Quark: MathLib[9c6aee55a3dfa27448f2948c7625d514e6de1e99], Quark: Automation[779512e00053ce04e8dde4c0f2be5fa9461bb2d0], Quark: FileLog[0.1], Quark: ExtraWindows[0.1.1], Quark: SignalBox[0.1.7], Quark: Hilbert[0.1.2], Quark: atk-sc3[4.0.3...etc...

I was hoping to see the installed version SuperDirt there.. Does supercollider chop off the info? You could it in Quarks.gui if so

Yes supercollider chopped of the rest. This is the output when I postline only the SuperDirt quark.

-> Quark: SuperDirt[a4f8ef040b5d3774f5ef9dd23324934dba56bd27]

Ok, that is over a year old, if you upgrade to superdirt v1.7.2 via Language > Quarks that should fix it.

(Strange though, normally tidal says 'waiting for supercollider..' if it's an old version.)

Hey, it's working now. So weird, because I did fetch for updates a couple of days ago.. Oh, well thanks for helping me out.

1 Like