SuperDirt error – Server 'localhost' exited with exit code 0 (solved)

I am on OSX 10.13.6. After quite a few attempts I was able to install the Tidal library via cabal v1-install tidal (thanks to the troubleshooting section in the Documentation).

At some point, when Tidal was still not installing, I had Superdirt running (SuperDirt: listening to Tidal on port 57120)

Now, I only get

-> SuperDirt
Booting server 'localhost' on address
Server 'localhost' exited with exit code 0.

I only have the Xcode command line tools installed at the moment. I am just mentioning it, because I think I might have had Xcode still installed when SuperDirt worked. Does ist matter at all?

Any pointers would be much appreciated... Thanks!!!

From the console log:

Process: scsynth [8415]
Path: /Applications/
Identifier: scsynth
Version: 0
Code Type: X86-64 (Native)
Parent Process: sclang [8094]
Responsible: scsynth [8415]
User ID: 501

Date/Time: 2021-08-01 02:07:31.558 +0200
OS Version: Mac OS X 10.13.6 (17G14042)
Report Version: 12
Anonymous UUID: 81C260AA-53AA-154D-5882-48D70E56B94C

Time Awake Since Boot: 5000 seconds

System Integrity Protection: disabled

Crashed Thread: 0 Dispatch queue:

Exception Codes: KERN_PROTECTION_FAILURE at 0x0000000106f0b000

Termination Signal: Bus error: 10
Termination Reason: Namespace SIGNAL, Code 0xa
Terminating Process: exc handler [0]

VM Regions Near 0x106f0b000:
__LINKEDIT 0000000106f09000-0000000106f0b000 [ 8K] rw-/rwx SM=NUL /Applications/
--> __TEXT 0000000106f0b000-0000000106f1b000 [ 64K] r-x/rwx SM=COW /Applications/
__DATA 0000000106f1b000-0000000106f1f000 [ 16K] rw-/rwx SM=COW /Applications/

Application Specific Information:
dyld: in dlopen()

Thread 0 Crashed:: Dispatch queue:
0 OscUGens.scx 0x0000000106f10af8 SinOsc_next_ika + 120
1 dyld 0x00000001075b4c5c ImageLoader::link(ImageLoader::LinkContext const&, bool, bool, bool, ImageLoader::RPathChain const&, char const*) + 260
2 dyld 0x00000001075a8f6a dyld::link(ImageLoader*, bool, bool, ImageLoader::RPathChain const&, unsigned int) + 161
3 dyld 0x00000001075b2046 dlopen + 429
4 libdyld.dylib 0x00007fff78767d86 dlopen + 86
5 scsynth 0x0000000105371ca8 PlugIn_LoadDir(boost::filesystem::path const&, bool) + 504
6 scsynth 0x000000010537163b initialize_library(char const*) + 875
7 scsynth 0x000000010538f5c5 World_New + 597
8 scsynth 0x0000000105346954 scsynth_main(int, char**) + 2004
9 libdyld.dylib 0x00007fff78766015 start + 1

and also

Thread 0 crashed with X86 Thread State (64-bit):
rax: 0x0000000106f0b000 rbx: 0x00007fac77d028d8 rcx: 0x0000000106f0b420 rdx: 0x0000000106f0b468
rdi: 0x0000000106f0b000 rsi: 0x0000000106f0b000 rbp: 0x00007ffeea8c0330 rsp: 0x00007ffeea8be458
r8: 0x0000000000000074 r9: 0x00000000000004c0 r10: 0x0000000000031001 r11: 0xffff80021af425a8
r12: 0x00007fac77c31d40 r13: 0x0000000000000000 r14: 0x0000000106f0b000 r15: 0x0000000106f10af8
rip: 0x0000000106f10af8 rfl: 0x0000000000010283 cr2: 0x0000000106f0b000

Logical CPU: 0
Error Code: 0x00000007
Trap Number: 14

I have uninstalled SuperCollider and all extenstions, quarks etc. and after a fresh install it seems to work.