Tidal 1.7 install problems

Hi Alex! thanks for this new upcoming things with the new version of tidal!!!
unfortunately I have a trouble trying to get to the new version.
I'm on a OS Catalina 10.15.4,
I did both of the steps with no problem but when I try to run any of the fresh ( #ampbus , #squizbus, press ) the post throws me this errors:

2 Likes

Hi, this probably means that you don't have the latest tidal installed. You can check by running tidal_version in the editor, it should say 1.7.

If you installed with cabal v1-update then cabal v1-install tidal, and it looks OK, probably you have a version installed a different way that is overriding it. When you start tidal it might give the location of a 'default' file - you can delete this, restart tidal and I think it would work then. Otherwise delete the .ghc and .cabal folders I mention in the top post to start from scratch.

1 Like

OK if you all upgrade SuperDirt to v1.7.1, the gain control should work again. Thanks @julian for the quick fix!

1 Like

i'm on manjaro and I'm getting this error

$ cabal v1-install tidal
Resolving dependencies...
Starting     tidal-1.7
Building     tidal-1.7
Failed to install tidal-1.7
Build log ( /home/chiffonmyst/.cabal/logs/ghc-8.10.3/tidal-1.7-LHBxG39auh07md9cRQ6FY4.log ):
cabal: Entering directory '/tmp/cabal-tmp-67963/tidal-1.7'
Configuring tidal-1.7...
Preprocessing library for tidal-1.7..
Building library for tidal-1.7..
[ 1 of 21] Compiling Paths_tidal      ( dist/build/autogen/Paths_tidal.hs, dist/build/Paths_tidal.o, dist/build/Paths_tidal.dyn_o )
[ 2 of 21] Compiling Sound.Tidal.Bjorklund ( src/Sound/Tidal/Bjorklund.hs, dist/build/Sound/Tidal/Bjorklund.o, dist/build/Sound/Tidal/Bjorklund.dyn_o )
[ 3 of 21] Compiling Sound.Tidal.Config ( src/Sound/Tidal/Config.hs, dist/build/Sound/Tidal/Config.o, dist/build/Sound/Tidal/Config.dyn_o )
[ 4 of 21] Compiling Sound.Tidal.Pattern ( src/Sound/Tidal/Pattern.hs, dist/build/Sound/Tidal/Pattern.o, dist/build/Sound/Tidal/Pattern.dyn_o )
[ 5 of 21] Compiling Sound.Tidal.Core ( src/Sound/Tidal/Core.hs, dist/build/Sound/Tidal/Core.o, dist/build/Sound/Tidal/Core.dyn_o )
[ 6 of 21] Compiling Sound.Tidal.Chords ( src/Sound/Tidal/Chords.hs, dist/build/Sound/Tidal/Chords.o, dist/build/Sound/Tidal/Chords.dyn_o )
[ 7 of 21] Compiling Sound.Tidal.Show ( src/Sound/Tidal/Show.hs, dist/build/Sound/Tidal/Show.o, dist/build/Sound/Tidal/Show.dyn_o )
[ 8 of 21] Compiling Sound.Tidal.Utils ( src/Sound/Tidal/Utils.hs, dist/build/Sound/Tidal/Utils.o, dist/build/Sound/Tidal/Utils.dyn_o )
[ 9 of 21] Compiling Sound.Tidal.Tempo ( src/Sound/Tidal/Tempo.hs, dist/build/Sound/Tidal/Tempo.o, dist/build/Sound/Tidal/Tempo.dyn_o )

src/Sound/Tidal/Tempo.hs:8:1: error:
    Could not find module ‘Sound.OSC.FD’
    There are files missing in the ‘hosc-0.18’ package,
    try running 'ghc-pkg check'.
    Use -v (or `:set -v` in ghci) to see a list of the files searched for.
  |
8 | import qualified Sound.OSC.FD as O
  | ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

src/Sound/Tidal/Tempo.hs:9:1: error:
    Could not find module ‘Network.Socket’
    There are files missing in the ‘network-3.1.2.1’ package,
    try running 'ghc-pkg check'.
    Use -v (or `:set -v` in ghci) to see a list of the files searched for.
  |
9 | import qualified Network.Socket as N
  | ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
cabal: Leaving directory '/tmp/cabal-tmp-67963/tidal-1.7'
cabal: Error: some packages failed to install:
tidal-1.7-LHBxG39auh07md9cRQ6FY4 failed during the building phase. The
exception was:
ExitFailure 1

Hm that doesn't look very healthy. Did you try deleting the ~/.ghc and ~/.cabal folders and trying again?

I just tried deleting both and got the same result. The only way I've been able to get Tidal working is by installing from the Official Repository.

Figured it out! I had to add export PATH="$HOME/.cabal/bin:$PATH" to my bash profile and then run cabal v1-install --ghc-options=-dynamic tidal

2 Likes

Hello, I updated Tidal but when I boot Tidal in Atom I get:
t> IO error: "C:\Users\cyberik.atom\packages\tidalcycles\lib" permission denied.

Hmm that's strange. @ndr_brt do you maybe know what's going on here?

I removed Boot Tidal Path in TidalCycle package settings and now I/O error disappear but Tidal is listening on 6010 port. I think it's the default port configured into the plugin. I changed Superdirt port but it doesn't work. I'm on Windows 10 64 bits. This workaround doesn't work because we need some settings in BootTidal.hs. I opened boot file, updated it and I can save it. So I don't understand why I get peremission denied.

I reinstall tidal with cabal ans I get this error.
Failed to build network-3.1.2.1. The failure occurred during the configure
step.
Build log (
C:\Users\cyberik\AppData\Roaming\cabal\logs\ghc-8.10.2\network-3.1.2.1-14e12666707deaad20f16a6650dea20a602b6c18.log
):
Configuring network-3.1.2.1...
cabal.exe: The package has a './configure' script. If you are on Windows, This
requires a Unix compatibility toolchain such as MinGW+MSYS or Cygwin. If you
are not on Windows, ensure that an 'sh' command is discoverable in your path.

cabal.exe: Failed to build network-3.1.2.1 (which is required by tidal-1.7).

This thing is new and I think can occur many errors on windows platform. Could you avoid installing Cygwin ?

My setup is using the WSL (Windows Subsystem for Linux) Version 1 (the Network Communication to Supercollider/Windows is different in Version 2), and runs really smooth (i have a "advanced" emacs setup and installing it was as easy as on linux, with every other solutions before I had a lot of different troubles). So yes, you can avoid to install cygwin.

But I havn't tried to install the update yet (maybe I will do this in the evening).

@Klinke Thanks, knowing Cygwin and not WSL, i installed it and using terminal, I finally installed Tidal 1.7 successfuly.
But Atom still raise same error when booting Tidal:
IO error: "C:\Users\cyberik.atom\packages\tidalcycles\lib" permission denied.
Question: When desinstalling atom package, is there some files cleaning to do after uninstall from atom settings?

Can you paste the whole tidal console output?

Hi, what do you mean by "tidal console"?

The panel where the IO error: "C:\Users\cyberik.atom\packages\tidalcycles\lib" permission denied. message appeared

That's in Atom log console.
Custom ghci path configured: C:\ProgramData\chocolatey\lib\ghc\tools\ghc-8.10.2\bin

Ghci command: C:\ProgramData\chocolatey\lib\ghc\tools\ghc-8.10.2\bin\ghci Ghc-pkg command: C:\ProgramData\chocolatey\lib\ghc\tools\ghc-8.10.2\bin\ghc-pkg

Load BootTidal.hs from C:\Users\cyberik.atom\packages\tidalcycles\lib

t>

t> IO error: "C:\Users\cyberik.atom\packages\tidalcycles\lib" permission denied

Strange because when I copy/paste the / between cyberik and .atom is not copied.
So there is a /.

Load BootTidal.hs from C:\Users\cyberik.atom\packages\tidalcycles\lib
t>
t> IO error: "C:\Users\cyberik.atom\packages\tidalcycles\lib" permission denied

The "BootTidal.hs" file path is wrong, that should indicate the file, not the folder.

(To see the \ before the . you should put the string in a "block code" like this: C:\Users\cyberik\.atom\packages\tidalcycles\lib)

I have already try this but when I add filename, I get:
t> Listening for controls on 127.0.0.1:6010
Rules for Boot Tidal Path are:

  • if configured, the file set in the Boot Tidal Path configuration
  • if exists, the one in the current directory
  • if exists, the one in the current Tidal installation, given by the ghc-pkg binary configured with Haskell Path
  • the fallback choice is the one included with the plugin
    In this case that's the fallback choice and that's wrong because we need custom boot file.