Tidal 1.7 install problems

No problem. It seemed like it couldn't find the PC based on the stuff i was seeing in Wireshark, yeah, except for that once.

Ok I think I have worked it out. I think the solution is to set the config setting cCtrlAddr = ""


tidal <- startStream (defaultConfig {cCtrlAddr = ""}) [(superdirtTarget {oAddress = "", oPort = 57120, oLatency = 0.11 ,oSchedule = Live, oWindow = Nothing, oHandshake = False, oBusPort = Nothing},  [superdirtShape]), (superdirtTarget {oAddress = "", oPort = 2020, oLatency = 0.1,  oSchedule = Live, oWindow = Nothing, oHandshake = False, oBusPort = Nothing}, [superdirtShape])]

I created an issue with some technical details here: https://github.com/tidalcycles/Tidal/issues/793

Sorry this took a while but thanks for reporting it!

That works! Thanks for sorting it so quickly.

1 Like

I think the problem i'm having might have something to do with this. i've tried pasting this into my Boottidal.hs file but still no difference.

The only thing that worked was reverting to the old version of Tidal but kinda defeats the point. :frowning_face:

You'd only hit this particular problem if you're running superdirt on a different computer to the one running tidal.

hello! i'm having a bit of trouble with the 1.7.2 install on macOS Catalina. i am currently running Tidal 1.6.1.

the terminal commands

cabal v1-update
cabal v1-install tidal

do not work for me so i used the normal method

cabal update
cabal install tidal

which appeared to successfully install 1.7.2.

when i run tidal_version in Atom i get "tidal 1.6.1"

@yaxu mentions in the main release post that Under linux/mac os can do this by removing the ~/.ghc and ~/.cabal folders.

i would like to do this but don't know the exact commands to type in terminal. can someone help?

ghc-pkg unregister tidal-1.6.1 doesn't do anything (error is: ghc-pkg: cannot find package tidal-1.6.1).

1 Like

Can't you delete the folder manually ? I remembet solving some Tidal update / install issues that way back when I was on OSX.

hey @nilhartman! i tried poking around but i don't actually know the filepath to where the ghc and cabal folders live :man_facepalming:

https://wiki.haskell.org/Mac_OS_X_Common_Installation_Paths :wink:

ok yes, so i did find the Haskell folder in my user library. if i delete this folder i will need to do a fresh install of Haskell, correct?

Yes. You can also just remove the Tidal 1.6.2 folder and then run the terminal commands to instal 1.7.2. At least I know I've done it and succeeded (was running Mojave though).

thanks! do you happen to know the filepath for the Tidal folder? i am trouble tracking that one down :worried: thanks man sorry for the dumb questions!

I wish I could tell but I no longer have a mac at my disposal :confused:

1 Like

The normal method is:

cabal install tidal --lib

Without the --lib it won't install. I don't understand why this flag is needed but it is :frowning:

1 Like

Oddly enough I deleted a Haskell install on Mojave just today. I found bits of it all over the place:

/Library/Frameworks/GHC.framework 1.12 GB
/Library/Haskell 107.2 MB
/Users/jsimon/Library/Haskell 1.02 GB
/Users/jsimon/.cabal 468 MB
/Users/jsimon/.ghc 146 KB

Deleted all of those and did a fresh install using ghcup, all went ok. Only stumbling block was the PATH business, finally got it working with this in my .bash_profile:

export PATH="$HOME/.cabal/bin:/Users/jsimon/.ghcup/bin:$PATH"

1 Like

@cleary was kind enough to screenshare and we wiped everything from the terminal and started from scratch. got rid of everything related to .ghc, .ghcup, .stack, and .cabal...there were billions of old files laying around so was good to get it cleaned up. everything worked great just doing the regular old cabal install tidal!


Hello All

I'm not getting any sound from Tidal using Atom.
I step through the guide Start tidalcycles and superdirt for the first time - TidalCycles userbase

I'm getting no errors in Sc and no errors in Atom booting, Sc tells me:
SuperDirt: listening to Tidal on port 57120
Atom on booting Tidal tells me:
Choose ghcup default path: /Users/admin/.ghcup/bin
Ghci command: /Users/admin/.ghcup/bin/ghci
Ghc-pkg command: /Users/admin/.ghcup/bin/ghc-pkg
Start atom-tidalcycles plugin
Load BootTidal.hs from /Users/admin/.cabal/share/x86_64-osx-ghc-8.10.4/tidal-1.6.1/BootTidal.hs
Loaded package environment from /Users/admin/.ghc/x86_64-darwin-8.10.4/environments/default
t> [TidalCycles version 1.7.2]
Installed in /Users/admin/.cabal/store/ghc-8.10.4/tdl-1.7.2-a2f498d7/share
Listening for external controls on
t> [TidalCycles v1.7.2]
t> Waiting for SuperDirt (v.1.7.2 or higher)..

But executing:
d1 $ sound "bd sn"
just returns the t> prompt and nothing sounds (I have sound from SuperCollider side)

Other Info:
cabal install --lib tidal
tells me all is up to date (on v1.7.2),
I installed Haskell via ghcup (currently on 8.10.4)
running SuperCollider 3.11.2
Mojave 10.14.6

Hi, Tidal is saying 'waiting for superdirt', which probably means that superdirt is out of date.

Try running this in supercollider:
Quarks.checkForUpdates({Quarks.install("SuperDirt", "v1.7.2"); thisProcess.recompile()})

If that fixes it, please let me know how you installed superdirt. It would be good to know how you ended up with an older version.


Many Thanks @yaxu that was the fix!

1 Like

Great, how did you install superdirt originally?