Tidal exits after connecting with superdirt

I'm in love with this software! I got it running on my studio desktop, but I'd really love to get it running on my linux laptop which I spend more time on when I'm not working in the studio, and which is (obviously) portable.

I have jack running, supercollider, superdirt! Now, when I run tidal in the terminal this is the output:

[TidalCycles version 1.7.10]
Installed in /nix/store/ljpdgxdfnc1p0lwvggr9sq68janxdbyy-tidal-1.7.10-data/share/ghc-9.0.2/x86_64-linux-ghc-9.0.2/tidal-1.7.10
Listening for external controls on
Connected to SuperDirt.

and then it plops me right back in the terminal!

when I execute a line in neovim this is the output:

Loaded package environment from /home/dot/.ghc/x86_64-linux-9.0.2/environments/default
GHCi, version 9.0.2: https://www.haskell.org/ghc/  :? for help
d $ sound "bd"
[TidalCycles version 1.9.3]
Installed in /home/dot/.cabal/store/ghc-9.0.2/tidal-1.9.3-029329aa11d70c94c7b0dc847fcc7e9fe521e4aee1273a3d8f74f2fcd0df47eb/share
Listening for external controls on
Connected to SuperDirt.
Loaded GHCi configuration from /home/dot/.local/share/nvim/plugged/vim-tidal/Tidal.ghci
tidal> d $ sound "bd"

<interactive>:1:1: error:
    Variable not in scope: d :: ControlPattern -> t

any ideas?

Welcome! I'm not specifically familiar with the vim/nvim plugin, so apologies if I miss anything, but the neovim plugin seems to be working correctly. The one issue there is that you're calling a nonexistent d function—the default Tidal setup defines numbered d1 through d16 functions, which I assume is what you wanted?

I'm not sure what's happening with your initial terminal usage, but the standalone Tidal binary is very experimental, and not actually used by any editor plugins that I know of, so it's entirely possible that it has some sort of bug. Neovim is loading Tidal in the more common (if more convoluted) way, so it shouldn't be affected by whatever is happening with the tidal command-line tool.

1 Like

Omg if that was my only issue I’m gonna faint. I can’t wait to try. I can’t believe I didn’t notice that. :joy::joy::joy:

who feels like a dunce? me. It's me. I do.

But I also feel magnificent because I could not be more excited about this running on my beloved nixos. SO HAPPY!!

Thank you so much! Such a silly mistake!!

1 Like

I just had so much fun live coding for thirty minutes in my beloved vim in my beloved nixos. I am so freaking excited and grateful. and I still feel a smidgen silly for my silly mistake lol


Glad it worked! The self-contained Tidal binary that one can run in the terminal is a dream that burns bright in our hearts, but it totally makes sense why it threw you off the trail here.


you're sweet! yeah, I think part of me was figuring that the vim version wouldn't function if the repl didn't work. but I also saved a test file with a typo and couldn't figure out why it wouldn't work. :laughing: lesson learned! <3

thanks again!!