Tidal Sounds won't work properly

Hello everyone!,
I recently tried to install tidalcycles, it's quite confusing at first, but then it is. Since i already got everything installed, but then the problem started when i tried to boot Tidalcycles from Atom. Here's the screenshot:

Somehow i couldnt play more than one sound in Tidal, such as samples and even the synth.
I currently use Mac with Catalina 10.15.7.

does that mean that you can only hear the sample once every time you execute the code, or only when you start Tidal?

Some more debug questions:

  • have you checked in the SuperCollider Post window if anything happened?
  • have you checked this link?

Only one sound everytime it executed

Yes, but nothing seems weird on it.
I also checked the link, but i'm not sure if i understand it. I tried to install "stack" but instead it shows something like this:

Hi @MariaAristya,
Hmm that's a strange problem ..

So when you run d1 $ s "bd", you only hear the sound once, not repeating?

Hallo @yaxu,
It is repeating, but when I combine it with another sound or synth by using stack, the secondary sound just wont come out.

I see you've got a sample (bd) and a synth (superchip) - these have some different behaviours:

d1 $ stack [
    s "bd*16",
    s "superchip*8"

What happens if you use another sample instead of the superchip synth?

d1 $ stack [
    s "bd*16",
    s "hh*8"

What happens if you change your superchip synth as follows:

d1 $ stack [
    s "bd*16",
    note "c" # s "superchip*8"
1 Like

Hi @MariaAristya,
I think this is because when the pattern runs over multiple lines, you have to run it in a different way.

  1. Make sure there is a blank line above and below the pattern, so it's separated by any other lines of code
  2. Put your cursor on it
  3. Run it with alt-enter, or I think on a mac it is cmd-enter

If you use shift-enter, it will only run a single line of code

Hi @yaxu,
It's working rightnow, but i figured it out when i use the "superchip" synth the sound doesn't came out. But now i tried it with "superpiano" and it worked! I don't why the sound with "superchip" won't come out. This is the codes that i use:


this is what i got on the SuperCollider:

Try this in SuperCollider:

SuperDirt.default = ~dirt;
(type: \dirt, s: \superchip, out: 0, n: 60).play

Do you hear any sound?

yes it's working, but there is a short high-pitched coming out

And this is how it should sound.
@cleary is right: superchip needs the note parameter for it to sound when you call it from within Tidal.

d1 $ note "c" # s "superchip"

will work, whereas

d1 $ s "superchip"

will not.