Tidal worked...I stopped for a while. Now it doesn't

I'm on a Mac running 10.15.7 which is what I was using when it worked.

I have attempted to uninstall and reinstall everything but the error is the same:

Choose **ghc** base path
> no custom path configured
*** use ghcup default path**

Ghci command: /Users/david/.ghcup/bin/ghci Ghc-pkg command: /Users/david/.ghcup/bin/ghc-pkg

Choose **BootTidal.hs** path
> no custom path configured
> not found in current directory
> cannot get tidal installation folder Error: Command failed: "/Users/david/.ghcup/bin/ghc-pkg" field tidal data-dir /bin/sh: /Users/david/.ghcup/bin/ghc-pkg: No such file or directory
*** use the default contained in the plugin**
* load BootTidal.hs from /Users/david/.atom/packages/tidalcycles/lib/BootTidal.hs

Cannot browse tidal to obtain informations for autocomplete: Error: Command failed: echo ":browse Sound.Tidal.Context" | "/Users/david/.ghcup/bin/ghci" /bin/sh: /Users/david/.ghcup/bin/ghci: No such file or directory

t> /bin/sh: /Users/david/.ghcup/bin/ghci: No such file or directory

I am not a smart man. Please help. I have tried to install Haskell via ghcup separately as well as the automatic installation script. My attempts to follow the uninstall instructions ( Open a terminal window and type uninstall-hs . This command will delete many things Haskell related from your computer.) failed as it told me uninstall is not a command.

When I first installed this about two years ago it worked immediately - and I honestly can't tell you if I have changed anything significant on my laptop (I don't think I have...)

Thank you for your help.

i feel like this has happened to me before, too, and i can't remember exactly what i did to fix it. i think what atom is telling you is that it is looking for a custom boottidal path when what you probably need to do is have it look for the default path, which is to say, nothing. if you try removing the boottidal path name under settings and then restart/re-boot and have it scan for the default instead, does it resolve the issue?

I’ll try that when I’m home and report back. It’s weird because it was working fine and I stopped for a year because my brain wasn’t feeling like coding and now I return and…oh no.

Who am I kidding? I have no idea what I'm doing.

THe error message is now:

Choose ghc base path

no custom path configured
*** use ghcup default path**

Ghci command: /Users/david/.ghcup/bin/ghci Ghc-pkg command: /Users/david/.ghcup/bin/ghc-pkg

Choose BootTidal.hs path
*** custom path configured**

  • load BootTidal.hs from ../desktop/BootTidal.hs

Cannot browse tidal to obtain informations for autocomplete: Error: Command failed: echo ":browse Sound.Tidal.Context" | "/Users/david/.ghcup/bin/ghci" /bin/sh: /Users/david/.ghcup/bin/ghci: No such file or directory

t> /bin/sh: /Users/david/.ghcup/bin/ghci: No such file or directory

should we try updating atom, supercollider/superdirt, and tidal?

That was the first thing I tried and the error messages continue (just seem to change). Honestly I’m using this as a sign it might be time for a clean install of my OS anyway!

1 Like

okay, maybe give the discord a shot as well to see if anyone else has any clues...

It looks like ghcup has at least one important file missing. You could delete it by removing the ~/.ghcup folder. From the commandline you could do this with: rm ~/.ghcup.

You could then try installing ghcup again. Or maybe you already have haskell installed another way, in which can removing ghcup might be enough to get it working again.

Appreciate the response but nothing seemed to work. Went ahead and did a full restore so I’ll report back later if I have any issues. Thank you!

OK, completely clean install of OS, new install of Tidal using the command line and still getting this error

Cannot browse tidal to obtain informations for autocomplete: Error: Command failed: echo ":browse Sound.Tidal.Context" | "/Users/david/.ghcup/bin/ghci" /bin/sh: /Users/david/.ghcup/bin/ghci: No such file or directory

t> /bin/sh: /Users/david/.ghcup/bin/ghci: No such file or directory

Update - manually installed ghcup and now the error message is

t>
: error:
Could not find module ‘Sound.Tidal.Context’
It is not a module in the current program, or in any known package.

Sometimes the error is

t>
Variable not in scope: d1 :: t0 -> t

• Variable not in scope: sound :: t1 -> t0
• Perhaps you meant ‘round’ (imported from Prelude)

shrugs

This means that haskell is installed fine but the tidal library isn't.

Have you tried:

cabal v1-update
cabal v1-install tidal

So I have it working now - but not entirely sure how. I will avoid messing with it and hope it continues. I appreciate everyone's help and I am excited to get back into it.

2 Likes